Building pyds and ImportError

Please provide complete information as applicable to your setup.

• Hardware Platform: Jetson
• DeepStream Version: 6.2
• JetPack Version: 5.1
• TensorRT Version: 2.11.0
• Issue Type: questions


I cloned the deepstream_python_apps repository and tried to build the pyds binding following the README here, using DS_VERSION=6.2, PYTHON_MAJOR_VERSION=3, PYTHON_MINOR_VERSION=8 and PIP_PLATFORM=linux_aarch64 as CMAKE options:
deepstream_python_apps/bindings at master · NVIDIA-AI-IOT/deepstream_python_apps · GitHub.

Then, when I run my own python code importing pyds, I get the following error:

Traceback (most recent call last):
  File "", line 11, in <module>
    from pipeline import Pipeline
  File "/home/jetson/git/blimp/jetson-agx/", line 13, in <module>
    import pyds
ImportError: /lib/aarch64-linux-gnu/ cannot allocate memory in static TLS block

However, running one of the deepstream_python_apps examples, it runs just fine.
I take it that I messed something up at some point.

Could someone help me understand the issue please?
Thank you in advance for your help

EDIT: It doesn’t solve the root cause, but there was an import pyds in my file and another in the file. By importing pyds before importing the pipeline file, the issue disappeared. :-/

Thanks all

There is no update from you for a period, assuming this is not an issue anymore. Hence we are closing this topic. If need further support, please open a new one. Thanks

  1. You should use: TensorRT Version:: TRT
  2. Your code may import some other libraries that affect memory allocation. Could you attach your a minimum executable demo code?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.