Building Video AI Applications at the Edge on Jetson Nano- BUG EXERCISE 1.1.4

Im getting this error when trying to follow the exercise. It seems that its not reading correctly the path of the config file. Tried to use an absolute path, but still not working. Please help.

Playing file /opt/nvidia/deepstream/deepstream-6.0/samples/streams/sample_720p.h264
Traceback (most recent call last):
File “”, line 332, in
File “”, line 224, in main
pgie.set_property(‘config-file-path’, “dstest1_pgie_config.txt”)
AttributeError: ‘NoneType’ object has no attribute ‘set_property’

These are the specs of my nano
**• Jetson Nano. Developer Kit Version
**• JetPack Version 4.6 {L4T 32.6.1}
• TensorRT Version
**• Exercise 1.14 bug config path not working

Did you build pyds bindings?

What do you mean by building pyds bindings?

I followed the next steps to set up my env (accordingly with the NVIDIA tutorial) :

(1) mkdir -p ~/my_apps

(2) sudo docker run --runtime nvidia -it --rm --network host \ -v /tmp/.X11-unix/:/tmp/.X11-unix \ -v /tmp/argus_socket:/tmp/argus_socket \ -v ~/my_apps:/dli/task/my_apps \ --device /dev/video1 \

Then I followed the 01)ObjDetect.ipynb and got the error when running:

Run the app

!cd $PYTHON_APPS/deepstream-test1-rtsp-out
&& python3 -i $STREAMS/sample_720p.h264

Follow this to build pyds

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.