Built rt-kernel system not using it (Solved)

Used the rt-patches to patch source and build kernel. Did module install and copied Image to the correct spot. But when I reboot a uname -a shows the original kernel. Am I missing a step?

Hello danpollock,

May I know if you were able to dd(1) the compiled Image in the /dev/mmcblk0p29 (partition called “kernel”). It had failed for me, and I didn’t give it a try again.

The way I am doing it is that I copy the Image file to the host system under “…/Xavier/Linux_for_Tegra/kernel/Image” (make sure you backup original Image in that dir). Then I ran flash.sh script to copy new Image on to Xavier. Verified with uname -a that new Image is running.

$ sudo ./flash.sh -k kernel jetson-xavier mmcblk0p1

Hope this helps.

Hi anish.aney,

So what you’re saying is that we can’t just copy the kernel image to the correct spot anymore and reboot like we could on the TX2 ?

On Xavier u-boot has been removed which means that the kernel images are no longer located on the /boot filesystem. The images are located in a ‘raw’ partition. The kernel is copied to partition 29. The best course of action is to use the flash.sh script as Anish has suggested.

See here for more information about the partitioning scheme on Xavier (r31).
https://devtalk.nvidia.com/default/topic/1039450/jetson-agx-xavier/custom-kernel-without-uboot/post/5281541/#5281541

Hmm…
Maybe that’s why my J20 camera expander board doesn’t probe :/
I have just copied it to /boot, will test, thanks guys :)

Hi Spawn32,

Right, it won’t work that way. It needs to be copied to partition /dev/mmcblk0p29, flash.sh worked for me. Same is applicable to copying dtb AFAIK.

Thank you so much guys,
I have been struggling for a week with this problem, did not know that you couldn’t “just” copy the image to /boot, i know they changed to flashing the dtb from 28.1 -> 28.2, but did not catch that you need to flash the kernel image from 4.0 ->.

It probes just fine now :)