BurnIn PassMark for the Jetson Nano/Xavier

Dear Team,
We are trying to get the BurnIn Passmark test suite to run our custom carrier board for the Jetson Nano/Xavier NX. When we run the test with admin privileges, the system is getting rebooted.

Power: 12V adapter @ 5A
Heat sink with fan: fan speed increases & system reboots
Used test suite: https://www.passmark.com/products/burnintest/bitlinux_arm_download.php
(arm v4 version)

Can you please help us in this regard?

Does it reboot immediate or run sometimes? any error log?

Hi,
I have 2 scenario,

  1. Without admin/root access: I am able to run the test and it generates the result log, but few of the tests can not be run without admin permissions. I have attached both config file and result log for review.
    BiTLog2.log (5.2 KB) cmdline_config.txt (7.2 KB)

  2. With root permission: If I provide admin permission(root user) and run the application, Immediately few error messages flash on the screen and system reboots, no log files can be seen when it gets rebooted. I am not able to capture the screen message as well since it only flashes for few seconds.

Could check the UART log if any validate message.

Hi roshan.dsouza,

I tried to reproduce your issue on Jetson Nano and Xavier-NX, but I can’t get system reboot issue.

Steps:
1.Flash r32.4.4 image on Nano/XavierNX
2. Run below commands:
$ sudo su
$ ./bit_cmd_line_aarch64

Please share your steps if any different with yours. Thanks!

Hi,
We have used the same steps. We have our additional patches for some peripherals like USB, Serial .but steps are same.
Should this work for previous L4T releases as well? Like r32.4.2 ,r32.4.3?

can you share the test logs and config file you have used?

Could you check the image without any patch? what kind of config do you need?

The config file & the test logs you might have captured on the Jetson Nano/XNX platforms.

have you installed or updated anything/tools/software else other than recommended in readme file?

Hey,
I get below error screen. and then if install all the not found packages i get the second screen and both the time system is getting rebooted immediately.

Could you try the pure system image. I think the test result from Carol wasn’t install any package.

Hi,
I have tried with stock BSP as well. but no change in the result. Still getting the issue, any suggestion?

Is your Nano devkit? Looks like devkit didn’t fan.

Could you please provide us with your test result logs & config file for Passmark? This would help us know whether our config file is incorrectly done.

Didn’t see the test result the APP just terminated and didn’t see the reboot issue.
Where to get the log? dmesg? what config file?

Get the log from the /tmp/

BiTLog2.log (5.4 KB)

This is the configuration file which we can change as per
our test requirements : cmdline_config.txt (7.2 KB)

By Default log file will be saved in /tmp path.
we can change this in configuration file attached.

Location (path) of log file

LogFilename /tmp/

Log prefix

LogPrefix BiTLog2

Here’s the cmdlin_config.txt from my NX

cmdline_config.txt (7.2 KB)