C250000.i2c prints

Hi,

Looking at the debugging console with an AGX devkit, I see these i2c print coming every few seconds

[  654.998261] tegra-i2c c250000.i2c: pio timed out addr: 0x1a tlen:28 rlen:4
[  654.998409] tegra-i2c c250000.i2c: --- register dump for debugging ----
[  654.998516] tegra-i2c c250000.i2c: I2C_CNFG - 0x22c00
[  654.998600] tegra-i2c c250000.i2c: I2C_PACKET_TRANSFER_STATUS - 0x10001
[  654.998713] tegra-i2c c250000.i2c: I2C_FIFO_CONTROL - 0x0
[  654.998803] tegra-i2c c250000.i2c: I2C_FIFO_STATUS - 0x800080
[  654.998894] tegra-i2c c250000.i2c: I2C_MST_FIFO_CONTROL - 0x70000
[  654.998991] tegra-i2c c250000.i2c: I2C_MST_FIFO_STATUS - 0x7c0000
[  654.999089] tegra-i2c c250000.i2c: I2C_MST_PACKET_TRANSFER_CNT - 0x0
[  654.999190] tegra-i2c c250000.i2c: I2C_INT_MASK - 0x7d
[  654.999277] tegra-i2c c250000.i2c: I2C_INT_STATUS - 0x2
[  654.999362] tegra-i2c c250000.i2c: i2c transfer timed out addr: 0x1a

Could someone explain me which device is trying to be reached and how to possibly disable this prints.

I can find a section in tegra194-soc-i2c.dtsi

	gen8_i2c: i2c@c250000 {
		#address-cells = <1>;
		#size-cells = <0>;
		iommus = <&smmu TEGRA_SID_GPCDMA_0>;
		dma-coherent;
		compatible = "nvidia,tegra194-i2c";
		reg = <0x0 0xc250000 0x0 0x100>;
		nvidia,hw-instance-id = <0x7>;
		interrupts = <0 TEGRA194_IRQ_I2C8 0x04>;
		scl-gpio = <&tegra_aon_gpio TEGRA194_AON_GPIO(DD, 1) 0>;
		sda-gpio = <&tegra_aon_gpio TEGRA194_AON_GPIO(DD, 2) 0>;
		status = "disabled";
		clock-frequency = <400000>;
		clocks = <&bpmp_clks TEGRA194_CLK_I2C8
			&bpmp_clks TEGRA194_CLK_PLLP_OUT0>;
		clock-names = "div-clk", "parent";
		resets = <&bpmp_resets TEGRA194_RESET_I2C8>;
		reset-names = "i2c";
		dmas = <&gpcdma 0>, <&gpcdma 0>;
		dma-names = "rx", "tx";
	};

For information, the devkit is only has an active network connection, no screen attached or anything.

Thanks,

Looks like the rt5659.7-001a the codec have i2c transfer failed cause this issue.
How can I see this message?

OK, so is that the audio codec?

I did disable audio in my kernel config with:

CONFIG_SOUND=m

Do I need to disable something else for the audio codec?

Maybe the device tree need to disable the rt5659