CAD importer broken?

Tried on three different machines now and they all throw this error:

Glad to see import tesselation settings now, but it seems actual importing is broken?

(Also, the import file dialog doesn’t seem to have a memory of the folder it last imported from? Tedious to navigate each time, especially since you can’t just press a letter key to jump to folders beginning with that letter like you can in the native Windows dialogs…)

@EDRobert i wonder if its something from the source file. have you tried importing in batches to see which piece(s) was incompatible and/or throwing the error (it should help you narrow down the error)? or you could DM Richard the file for troubleshooting/repro when he requests it.

One thing I see is that you have spaces in your filename and pathing. I can see %20 in your path names. You have “Preliminary Files”. Try removing the space. This may help with the errors.

If not please attached the full log. I have emailed you as well.

Wow, I honestly don’t know what to say to that. Was the USD standard written in the 1980s? 😄

But that doesn’t make any sense because I’m able to run local files with spaces in their filenames and directory structure with no issue… this restriction seems to be only something the CAD Importer has problems with?

Also, I just tried moving and renaming the file to something without spaces in and “luckily” that fails with the same error. I say luckily, because that would have been the silliest showstopper ever! 🙂

I haven’t received the mail yet, but where do I find the full log?

Open up the “Console” and click here to access the log

We have identified the issue and we will be releasing a hotfix to this problem in the next few weeks.

I have the same problem.
kit_20231201_141155.log (1.4 MB)

Yes we are aware and apologize. We are releasing a hotfix any day now that fixes this. Look for version 2023.2.2

The work around is to convert your project to USD in other software and then use one of our connectors for now.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.