Camera blinking issue

Hello,

I’m using Jetson Nano 4gb with ar0144 attach to it. I manage to make all the necessary customization to make this camera work with GRAY8 format. However, when I execute gstreamer I get this blinking stream from the camera. Any tips to solve this issue ?

Thanks.

hello tunakayakaan,

may I know what’s your command-line to enable preview stream,
could you please try to enable the stream with AE_Lock?

gst-launch-1.0 v4l2src device=/dev/video0 ! “video/x-raw, format=(string)GRAY8, width=(int)1280, height=(int)720, framerate=(fraction)30/1” ! videoconvert ! xvimagesink sync=false & dmesg -w

This is the command-line to enable preview stream

After adding AE_Lock with this:
gst-launch-1.0 v4l2src device=/dev/video0 ! “video/x-raw, format=(string)GRAY8, width=(int)1280, height=(int)720, aelock=true, framerate=(fraction)30/1” ! videoconvert ! xvimagesink sync=false & dmesg -w

The result is the same

hello tunakayakaan,

it looks like sensor register programming issue, for example, please have a try to report the same frame-length register settings for testing.

Hi Jerry,

I almost changed every register to its default value by looking into ar0144’s datasheet but problem still valid. If this was a device tree issue, where would you look first ?

hello tunakayakaan,

suggest you should hack your sensor driver to limit all CID controls for programming registers.
for example, to disable all your set exposure, set framerate,…etc sensor controls, launching the streaming with sensor init mode table configurations.

Okay so found the solution by myself while scanning ar0144.c file. For some reason inside of “static const struct ar0144_mode supported_modes” I need to set width and height to 1280, 800… But the camera still starts streaming on 1280x720. Its strange but if anyone comes across the same problem, you’re welcam.