Camera calibration error: Could not make progress initializing the world positions

Please provide the following info (check/uncheck the boxes after creating this topic):
Software Version
DRIVE OS Linux 5.2.6
DRIVE OS Linux 5.2.6 and DriveWorks 4.0
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version
other

Target Operating System
Linux
QNX
other

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)
other

SDK Manager Version
1.8.0.10363
other

Host Machine Version
native Ubuntu 18.04
other

Hi,

I get this error when I run sudo ./calibration-graph-cli --dir=/usr/local/driveworks/tools/calibration/calibration_data

Terminating app due to unexpected exception:
Could not make progress initializing the world positions. This probably indicates a disconnected graph. Check that all targets are detected in the images and that there are enough targets and images to link all cameras. Nodes with missing poses: external,

I have added 52 images from the external camera. I am using targets 90-97. I have attached my terminal output below.

terminal_output.txt (93.1 KB)

Hi @mamoona.b.shami
We will check internally and get back to you. Thanks.

Looks like you don’t have a complete graph. Image should be connected to all other images by observing the same targets, maybe they have some isolated observation.

This can also happen if some targets don’t get detected if they are too far away or too blurry or something.

Hi,

We repeated the experiment and still got the same error. I am attaching the files here and maybe you can take a look and see what are we doing wrong in this setup?

https://drive.google.com/drive/folders/18PpB93oIGG-yMb7gYZWSvaPGX94lX9oS?usp=sharing

However, we were able to run the calibration on driveworks 4.0 and it worked. But when we try to get the world coordinates of the same point in two cameras using the code provided here:

The result is different from different cameras which leads to the conclusion that calibration might be incorrect ? Any suggestions?

Did you mean DW3.5 hit “Could not make progress initializing the world positions” issue but DW4.0 didn’t?

DW3.5 gives this error but no other details, while DW4.0 shows which external images have large errors so we removed those images and tried to calibrate again and were able to generate a rig.json file. However, using the code given by @FabianWeise, the same point seen from 2 different cameras returns different world coordinates which led us to believe the calibration might be incorrect.