Camera Crashing with video-viewer

Hello.
I recently purchased a camera from Ali Express, the datasheet is attached, for some weird reason the camera keeps on crashing on the Jetson Nano with a Segmentation Fault error. I have used the same camera on windows and it works fine, but it crashes on the nano.
It would be great if someone could help me with this.


NLK-2MP08S datasheet 38-38mm_wrapper (1).pdf (1.3 MB)

How about gst-launch v4l2src … command?

@ShaneCCC Same result.

If v4l2src get the same result I would like to say it could be the device compatibility problem.
Could you check if able run on any x86 ubuntu devices.

Yes, I agree but the device suppers UVC Protocol and the camera works fine when I use a 90 FOV lens with it.

Maybe need more investigate to figure the problem.

What more do you need?

Maybe check with any other linux platform to confirm it. Also consult with Ali if any further information.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.