Camera doesn't work with SPI2 set to slave, Cannot make SPI1 work as slave

I have a nano that generates test data and transmits it on SPI1. I have another nano that receives it on SPI2. This much is working. The test data is a mock up of data that will be coming from an embedded processor in the real system.

When I have SPI2 configured as a SPI slave, I can not get the camera to work. If I change it to a SPI master, the camera works fine.

Okay, so, no problem, I originally made SPI2 the slave because I thought I’d want a loopback test. Something I never actually worked on.

So, I tried setting up SPI1 as the slave. The Camera works in this configuration, but, I cannot receive data on SPI1.

Is there some reason I should expect the camera to interfere with SPI2? Is there some reason why SPI2 should work as a slave and not SPI1?

There’s no any restrict which SPI much be master or slave.

Is there any reason the SPI2 should interfere with the Camera?

It’s literally the only thing I’m changing in the DTS->DTB files.
Changing spi-tegra210 to spi-tegra124-slave in the compatibility line breaks the camera.

I think the camera can’t be slave mode.
For the v4l2 camera driver the camera sensor driver should be implement as slave mode.