Camera Focus doesnot work when DeepStream runs

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU)
Jetson Nano 2GB
• DeepStream Version
• JetPack Version (valid for Jetson only)
• TensorRT Version
• NVIDIA GPU Driver Version (valid for GPU only)
• Issue Type( questions, new requirements, bugs)
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

Hi, I am using Arducam IMX519 and it has autofocus and manual focus feature, it works when I run its Focuser file to focus specific distance. But when I run deepstrea-app -c source1_csi… example app, the focus remains only two sec than returns totally blur camera cannot focus again, and I want to put this focuser file into deepstream app to solve it very quick but don’t know how to.
Any advice could be nice.
Have a nice day!

Autofocus is not supported, you may need to check with sensor vendor on sensor configuration.

Can I just solve it by putting codes (python) implementing the codes from arducam or do I need to change source code of deepstream ?
Is SWIG (Simplified Wrapper and Interface Generator) applicable for deepstream?

deepstream-app is opensource, it will uses nvarguscamerasrc plugin to capture raw data from CSI camera, you can modify the deepstream-app if needed.

I know I can but it will take time, I solved it with another solution. Thanks!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.