Camera only produces one frame, please help take a look

Hi.I have two cameras, each of which can only produce one image. Please help me check the reason, thank you!
Why is there no complete video stream.Same configuration, IMX390 is not a problem.

gst-launch-1.0 -ev v4l2src device=/dev/video0 ! rawvideoparse format=4 width=1920 height=1080 ! videoconvert ! fpsdisplaysink video-sink=
xvimagesink sync=false

environment:
soft:
JP5.1.2
tegra234-camera-ar0233-a00.txt (25.9 KB)

Hardware:

Key Feature:
Sensor: ISX031
Sensor Size: 1/2.42”
Pixel size: 3.0um
ISP: Chip bring
Resolution: 19201536(30fps) ---------> actual output size 2200 × 1750
Output format YUV422 8 bit(UYVY)
Lens structure 6G+IR
FOV: H:58±3 V:44±3
Serializer: MAX9295A
Connector: FAKRA male type Z
Voltage: 8V~16V
Current <100mA(@12V)
Power
consumption <1.2W
Water proof IP69K
Operation
Temp -40℃~+85℃
Storage Temp -40℃~+95℃
Size: L30
W30*H39.02
Weight: <60g

sudo su
cd /sys/kernel/debug/dynamic_debug/
echo file csi2_fops.c +p > control

echo 1 > /sys/kernel/debug/bpmp/debug/clk/vi/mrq_rate_locked
echo 1 > /sys/kernel/debug/bpmp/debug/clk/isp/mrq_rate_locked
echo 1 > /sys/kernel/debug/bpmp/debug/clk/nvcsi/mrq_rate_locked
echo 1 > /sys/kernel/debug/bpmp/debug/clk/emc/mrq_rate_locked
cat /sys/kernel/debug/bpmp/debug/clk/vi/max_rate |tee /sys/kernel/debug/bpmp/debug/clk/vi/rate
cat /sys/kernel/debug/bpmp/debug/clk/isp/max_rate | tee /sys/kernel/debug/bpmp/debug/clk/isp/rate
cat /sys/kernel/debug/bpmp/debug/clk/nvcsi/max_rate | tee /sys/kernel/debug/bpmp/debug/clk/nvcsi/rate
cat /sys/kernel/debug/bpmp/debug/clk/emc/max_rate | tee /sys/kernel/debug/bpmp/debug/clk/emc/rate
echo 1 > /sys/kernel/debug/tracing/tracing_on
echo 30720 > /sys/kernel/debug/tracing/buffer_size_kb
echo 1 > /sys/kernel/debug/tracing/events/tegra_rtcpu/enable
echo 1 > /sys/kernel/debug/tracing/events/freertos/enable
echo 2 > /sys/kernel/debug/camrtc/log-level
echo 1 > /sys/kernel/debug/tracing/events/camera_common/enable
echo > /sys/kernel/debug/tracing/trace
cat /sys/kernel/debug/tracing/trace

trace log:
trace.log (796.1 KB)

Moving this topic to the Orin NX category for visibility

CHANSEL_NOMATCH could be the embedded_data_height incorrect in device tree.

Thanks

Sorry for the late reply. I have confirmed with the camera manufacturer, embedded_ Data_ Height should be set to 0.

Summary
		i2c@1 {
			reg = <0x01>;
			i2c-mux,deselect-on-exit;
			#address-cells = <0x01>;
			#size-cells = <0x00>;

			ar0233_a@1b {
				compatible = "nvidia,ar0233";
				reg = <0x1b>;
				physical_w = "15.0";
				physical_h = "12.5";
				sensor_model = "ar0233";
				post_crop_frame_drop = [30 00];
				use_decibel_gain = "true";
				use_sensor_mode_id = "true";
				def-addr = <0x10>;
				clocks = <0x02 0x24 0x02 0x24>;
				clock-names = "extperiph1\0pllp_grtba";
				mclk = "extperiph1";
				channel = [61 00];
				nvidia,gmsl-ser-device = <0x6f>;
				nvidia,gmsl-dser-device = <0x70>;

				mode0 {
					mclk_khz = "24000";
					num_lanes = [34 00];
					tegra_sinterface = "serial_c";
					vc_id = [30 00];
					discontinuous_clk = "no";
					dpcm_enable = "false";
					cil_settletime = [30 00];
					dynamic_pixel_bit_depth = "16";
					csi_pixel_bit_depth = "16";
					mode_type = "yuv";
					pixel_phase = "yuyv";
					active_w = "1920";
					active_h = "1536";
					readout_orientation = [30 00];
					line_length = "2800";
					inherent_gain = [31 00];
					pix_clk_hz = "115500000";
					serdes_pix_clk_hz = "375000000";
					mclk_multiplier = [34 00];
					gain_factor = "100";
					min_gain_val = "100";
					max_gain_val = "1200";
					step_gain_val = [31 00];
					default_gain = "100";
					min_hdr_ratio = [31 00];
					max_hdr_ratio = [31 00];
					framerate_factor = "1000000";
					min_framerate = "10000000";
					max_framerate = "30000000";
					step_framerate = [31 00];
					default_framerate = "30000000";
					exposure_factor = "1000000";
					min_exp_time = "49";
					max_exp_time = "40000";
					step_exp_time = [31 00];
					default_exp_time = "12000";
					embedded_metadata_height = [30 00];
				};

				ports {
					#address-cells = <0x01>;
					#size-cells = <0x00>;

					port@0 {
						reg = <0x00>;

						endpoint {
							vc-id = <0x00>;
							port-index = <0x02>;
							bus-width = <0x04>;
							remote-endpoint = <0x71>;
							phandle = <0x297>;
						};
					};
				};

				gmsl-link {
					src-csi-port = [61 00];
					dst-csi-port = [61 00];
					serdes-csi-link = [61 00];
					csi-mode = "1x4";
					st-vc = <0x00>;
					vc-id = <0x00>;
					num-lanes = <0x04>;
					streams = "ued-u1\0raw12";
				};
			};

The DTS file is attached below:
dts.txt (424.3 KB)

trace 如下:

Summary

root@tegra:/home/robot# echo 1 > /sys/kernel/debug/bpmp/debug/clk/vi/mrq_rate_locked
echo 30720 > /sys/kernel/debug/tracing/buffer_size_kb
echo 1 > /sys/kernel/debug/tracing/events/tegra_rtcpu/enable
echo 1 > /sys/kernel/debug/tracing/events/freertos/enable
echo 2 > /sys/kernel/debug/camrtc/log-level
echo 1 > /sys/kernel/debug/tracing/events/camera_common/enable
echo > /sys/kernel/debug/tracing/trace
cat /sys/kernel/debug/tracing/trace
root@tegra:/home/robot# echo 1 > /sys/kernel/debug/bpmp/debug/clk/isp/mrq_rate_locked
root@tegra:/home/robot# echo 1 > /sys/kernel/debug/bpmp/debug/clk/nvcsi/mrq_rate_locked
root@tegra:/home/robot# echo 1 > /sys/kernel/debug/bpmp/debug/clk/emc/mrq_rate_locked
root@tegra:/home/robot# cat /sys/kernel/debug/bpmp/debug/clk/vi/max_rate |tee /sys/kernel/debug/bpmp/debug/clk/vi/rate
832000000
root@tegra:/home/robot# cat /sys/kernel/debug/bpmp/debug/clk/isp/max_rate | tee /sys/kernel/debug/bpmp/debug/clk/isp/rate
1011200000
root@tegra:/home/robot# cat /sys/kernel/debug/bpmp/debug/clk/nvcsi/max_rate | tee /sys/kernel/debug/bpmp/debug/clk/nvcsi/rate
642900000
root@tegra:/home/robot# cat /sys/kernel/debug/bpmp/debug/clk/emc/max_rate | tee /sys/kernel/debug/bpmp/debug/clk/emc/rate
3199000000
root@tegra:/home/robot#
root@tegra:/home/robot# echo 1 > /sys/kernel/debug/tracing/tracing_on
root@tegra:/home/robot# echo 30720 > /sys/kernel/debug/tracing/buffer_size_kb
root@tegra:/home/robot# echo 1 > /sys/kernel/debug/tracing/events/tegra_rtcpu/enable
root@tegra:/home/robot# echo 1 > /sys/kernel/debug/tracing/events/freertos/enable
root@tegra:/home/robot# echo 2 > /sys/kernel/debug/camrtc/log-level
root@tegra:/home/robot# echo 1 > /sys/kernel/debug/tracing/events/camera_common/enable
root@tegra:/home/robot# echo > /sys/kernel/debug/tracing/trace
root@tegra:/home/robot# cat /sys/kernel/debug/tracing/trace

tracer: nop

entries-in-buffer/entries-written: 0/0 #P:8

_-----=> irqs-off

/ _----=> need-resched

| / _—=> hardirq/softirq

|| / _–=> preempt-depth

||| / delay

TASK-PID CPU# |||| TIMESTAMP FUNCTION

| | | |||| | |

root@tegra:/home/robot# cat /sys/kernel/debug/tracing/trace > trace.log
root@tegra:/home/robot#

trace.log (690.1 KB)

Below log tell PIXEL_RUNAWAY that could be the output pixel more than expected.

CHANSEL_FAULT channel:0x23 frame:0 vi_tstamp:1585576297056 data:0x0000000004380040

I also believe it is related to pixels.

Under the condition of unchanged dts.

gst-launch-1.0 -ev v4l2src device=/dev/video2 ! rawvideoparse format=4 width=1920 height=1536 ! videoconvert ! fpsdisplaysink video-sink=xvimagesink sync=false

gst-launch-1.0 -ev v4l2src device=/dev/video2 ! rawvideoparse format=4 width=1920 height=1080 ! videoconvert ! fpsdisplaysink video-sink=xvimagesink sync=false

Is this still an issue to support? Any result can be shared?

Sorry for the late reply. Today, the problem of positioning and driver code (the driver resolution was written wrong) has been solved. Thank you!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.