Cameras became unavailable after FE-PI install


We are using SerDes cameras from Appropho and FE-PI AUDIO Z V2 audio modules on Jetson Nano.

First we intall the cameras and after we enable the audio board with /opt/nvidia/jetson-io/
After this we cannot access the cameras any more.

We try with the following gstreamer comand
$ gst-launch-1.0 nvarguscamerasrc sensor-id=0 sensor-mode=0 gainrange=“1 16” ispdigitalgainrange=“1 1” ! ‘video/x-raw(memory:NVMM), width=(int)1948, height=(int)1096, format=(string)NV12, framerate=(fraction)30/1’ ! nvvidconv ! fpsdisplaysink video-sink=xvimagesink -e
GST_ARGUS: NvArgusCameraSrc: Setting Gain Range : 1 16
GST_ARGUS: NvArgusCameraSrc: Setting ISP Digital Gain Range : 1 1
Setting pipeline to PAUSED …
Pipeline is live and does not need PREROLL …
Setting pipeline to PLAYING …
New clock: GstSystemClock
Error generated. /dvs/git/dirty/git-master_linux/multimedia/nvgstreamer/gst-nvarguscamera/gstnvarguscamerasrc.cpp, execute:645 No cameras available
(gst-launch-1.0:9260): GStreamer-CRITICAL **: 15:56:16.207: gst_mini_object_set_qdata: assertion ‘object != NULL’ failed
Got EOS from element “pipeline0”.
Execution ended after 0:00:00.092468110
Setting pipeline to PAUSED …
Setting pipeline to READY …
Setting pipeline to NULL …
Freeing pipeline …

But the cameras are visible under:
ll /dev/video*
crw-rw----+ 1 root video 81, 0 May 5 15:22 /dev/video0
crw-rw----+ 1 root video 81, 2 May 5 15:22 /dev/video1

We tried this on 4.4.1 and 4.5.1 releases but the result is the same. Its not even needed to attach the FE-PI to the Nano after

Appropho camera

Do you have any idea what can go wrong?

Thanks you!


The tool jetson-io will override the device tree that could cause the context of sensor configure in device tree loss.
You can use dtc to disassemble dtb in /boot/ to find what jetson-io add for audio and then add them manually to your device tree.