Can I run Isaac Sim on VMware Horizon?

Hi, can I run Isaac Sim on VMware Horizon?
I try to run Isaac Sim on VMware Horizon (Ubuntu 18), but Isaac Sim can’t detect cuda. The errors are:

[Error] [carb.cudainterop.plugin] CUDA error 46: cudaErrorDevicesUnavailable - all CUDA-capable devices are busy or unavailable)
[Error] [carb.cudainterop.plugin] Failed to create CUDA stream.

Hi, can you post the out put of nvidia-smi? Does any other CUDA enabled application work?

The output of nvidia-smi:

No, I didn’t run any other CUDA enabled application. This was the output of nvidia-smi after running Isaac Sim:

Hi, please provide more info on your setup and a log file of Isaac Sim.

I believe the issue could be caused by Blast. Can you try disable Blast when running the Horizon server?

Hi, I can’t disable Blast. Because I’m not the owner of this server (But I will ask the owner to disable Blast)
Or Can I disable it from client? I tried this setting, but the problem still occurred
Ubuntu 18 is totally new. I only install Isaac Sim on it.
This is the log of Isaac Sim:omniverse-kit.log (157.5 KB)

Sorry, I think it might not be related to Blast. I got it working even with Blast.

Can you try checking the “Allow H.264 decoding” option?
Also, is it possible if you try on a different Client OS. Maybe on Windows?

Btw, Isaac Sim still runs even with those errors mentioned. Did the Isaac Sim window appear for you?

After checking the “Allow H.264 decoding” or try client on Windows, the CUDA erros still occurred.

Yes, Isaac Sim can run with these errors. But the simulation runs very slow (FPS is only 3)

Have you got it resolved? I believe one of our engineers have sent you a fix. Please try this if you have not got it resolved yet.

  1. sudo nano /etc/vmware/config
  2. Uncomment the RemoteDisplay.maxFPS line so its now set to 30, apparently the range is 3 → 60.
  3. Reboot

I just run Isaac Sim, the CUDA errors disappear (FPS is 30).
However, After shutting down Isaac Sim and run it again. The CUDA errors show up again (FPS goes back to 3).
Could you please check it for me? Thanks!

Hi, I have tried running it again after a reboot and I can get 60 FPS with the Leonardo Preview sample. Please give it a try again.

Hi, the CUDA errors disappeared.
I tried running Leonardo Preview sample (Simple Stack), but FPS is only 15.