Can I use an older runtime library with CUDA 10.2?

I recently updated from an early CUDA toolkit to 10.2 and was very happy with the improved profiling and debugging tools. But I am now horrified to find that my recompiled apps no longer run on my customers’ computers! This is because cudaGetDeviceCount() fails with the error “CUDA driver version is insufficient for CUDA runtime version.” which did not happen when I compiled with my old version.

From the documentation it seems that this is because more recent runtime libraries don’t run with older devices/drivers. Surely there must be a workaround! Upgrading my development tools should not break my code on older computers. Please help!