Can it work board from jetson TX1 developer kit with jetson tx2 module?

I have jetson TX1 developer kit and would like to test my sowtware on TX2. May i buy only module of TX2 and place it on board from jetson TX1 developer kit?
Are there any problems when I running the module on this Board?
Does the TX2 module also come with a pre-installed system? Or i need install it by my self?

The earlier carrier boards didn’t have all of the wiring of the ones which came out after the TX2 hit the market. The old carrier would not hurt a TX2, but might be missing some optional wiring.

The newer carrier boards (which might actually be considered old since they starting shipping for both a TX1 and TX2 quite some time back) will work with either a TX1 or TX2 and would be completely interchangeable.

If you buy just a TX2 module and the carrier is the right revision (I don’t know which revision number had the needed change to make the carrier useful with both a TX1 and TX2…anyone know?), then you only need the module. On the other hand, if it turns out you need a new carrier board, then it isn’t possible to later purchase a dev board carrier…those carriers are only available with the purchase of a TX2 as a kit.

The dev kit comes with an old version of L4T installed. It would be highly advisable to flash to the latest version even though it has software.

The pure module purchase does not have software on it must be flashed.

Note: Third party carrier boards also require flash of the Jetson since configuration details differ. You can switch between carrier boards with a single module, but would typically need to flash each time with the correct board support package.

Hi,

I prototype my own PCB For Jetson. By your answer i understand that i need chsnge something wireles in it. May i see/download changes in main circuits? Or maybe you have univesal shematic for TX1 and TX2?

See:
https://developer.nvidia.com/embedded/downloads

Under “Product” and “Hardware” check those which apply to you. Often, when designing a new carrier, the document to look at first is “Jetson TX2 Platform Adaptation and Bring-Up Guide” (you can put “adaptation” in the search box to limit to this).

You can also put “schematic” in the search box.

That would be the latest C02 carrier board revision. See this post for how to tell which you have:

https://devtalk.nvidia.com/default/topic/1037710/jetson-tx2/how-to-find-carrier-board-version/post/5272044/#5272044

FYI, the C02 link fails due to a read error of the file on the server.

Hmm I just tried downloading it again and it works OK on my end, maybe try clearing cache and logging in again?

Still fails for me. B04 downloads without error, but C02 says it could not be saved because it could not be read…try again later, or contact the server administrator. Perhaps coming from an outside address responds differently than from an inside address.

I tried from my phone on wireless and the download completed OK. Maybe it is geographically-related - I will have them flush the CDN cache for the file.