Can no longer flash Jetson Tx2


So I’ve been trying to get a Tx2 to work an an Auvidea J120 board. So I successfully flashed the modified kernel and got it booted with the ports working. Then after working on it for a bit it suddenly went black and it wont boot on the J120 board and more. I’ve tested the power and everything is working fine but it just wont turn on. So I decided to try re-flashing the Tx2. However I can no longer flash it. I can see the board in lsusb but in ifconfig it doesn’t show up. Here are the details:

It has the modified kernel for the Auvidea J120 version 2.0.
I am flashing from a non-VM system, I’ve tried both Ubuntu 16.04 and 18.04.
I can boot the Tx2 on the Dev board but not on the Auvidea J120.
While it is booted normally I can see it through the micro usb under ifconfig like normal.
When I put it in recovery mode to flash it, it disappears from ifconfig. It’s still in lsusb.
I’ve reset the network files to defaults.
When I try to flash it it says it gets to about 8% and then says it cannot find hardware.

Thanks for the help,

Hi Andrew,

It sounds some hardware problem on your J120 board. Are you able to get serial console log fomr J120 board?

I will give that a shot but I cannot boot the system on the j129 board.

The bigger problem however is that I can’t reflash the tx2 at all even on the dev board.

The bigger problem however is that I can’t reflash the tx2 at all even on the dev board.

Then maybe the module itself has some problems. Could you share

  1. The flash log on host

  2. Enabled the serial console from tegra through minicom and it should also spew logs during flash. Please share this to us. This log is important to check your issue.

Have you tried with another cable? It happened to me once that the cable had some issues and I couldn’t flash the TX2 successfully. I changed the cable, and problems gone.