Can not access in Ubuntu

Hello,
I’m using nVidia Jetson Tx2 on Ubuntu 16.04.
Today when I open Ubuntu, I write my password for ubuntu but this not work.
If I write wrong pass so this show: “Invalid password” and while I write correct pass so the desktop off -> on. I can’t access into my work desktop
What’s wrong? Can you help me. Please.
Thank you very much

Was this the default password, or was it something you added? If default, and if the system touches the outside world without some sort of protection, then I’d say it someone did something malicious. On the other hand it sounds like you might have a custom password…in which case something else is going on. Do you have serial console? Serial console will always log in without a password and can be a good way to see what’s going on.

If you go to console via CTRL-ALT-F2, can you log in on text-only console?

If you are using a non qwerty keyboard, it might also be a keymap failure (I’ve seen this with some startup errors). In most cases you would see it when typing user ‘nvidia’, but for ‘ubuntu’ the confusion is possible. In such case you would try to enter your password as on a qwerty keyboard.

Hello linuxdev,
Thanks for your support.
This is the dafault password.
I still log in with ctr + alt + f2. But I can not access in any folder. Example: when I write: cd Downloads, so the desktop response a error: “no such file or directory”.

Hello honey_Patouceul.
Thanks for your response.
I think the isue is not write wrong password. Be cause when I write some characters so it show “invalid password”, it is different with I write my password.

You may first check if your disk is full:

df -H -T

If it shows / used at 100%, it is possible that some errors have created huge log files in /var/log that you would delete.

If this is not enough, also check if this command works:

sudo /bin/ls

If it returns an error such as ‘sudo: /usr/bin/sudo must be owned by uid 0 and have the setuid bit set’, then the problem could be having created your roofs on host on a non linux filesystem.

Hello Honey_Patouceul,
I tried your solution and this is result:

And

Wait for your response!
Thanks!

I have the same question @Honey_Patouceul asked: What do you see as a response if you run “df -H -T”? Does “sudo ls” work or does it give an error?

When you go to the text console with CTRL-ALT-F2, is there a login prompt? Does login fail?

Do you have a serial console cable?

Hello linuxdev,
Thanks for your response,
Yes, I have a serial console cable.
I’m can login with CTRL - ALT - F2, but I can do any work.
I will show you my result when run this code:


You still have disk space, and it seems the basic command is working.

So probably the next step is that while you are in the serial console run this command so you will see log notes in real time as they occur:

dmesg --follow

Now, from an outside system, see what happens when you try to log in via ssh, or even locally at a terminal.

Should that not reveal any useful information, then from the serial console run this instead of dmesg:

sudo tail -f /var/log/auth.log

What shows up during a failed login attempt when you are monitoring dmesg or auth.log? “dmesg” does not require sudo, but watching auth.log does.

This is result after I run code sudo tail -f /var/log/auth.log:
Imgur

Looks like the image URL isn’t valid. FYI, on serial console you can usually copy and paste on the host, so you might be able to just save the session and attach as a “.txt” file. If you do want to attach a file, then hover the mouse over the quote icon in the upper right of an existing post and you will notice a paper clip icon show up…the paper clip icon is the attach mechanism.

Also, after a login at the serial console, what do you see from “ls -ltr”?