Can not add the nvcc compiler to Netbeans 6.9.1

Hi,

I will use Netbeans 6.9.1 IDE on Ubuntu 10.04 for CUDA programming. I found some recommendations on: http://forums.nvidia.com/index.php?showtopic=57297&st=0
But I can not add Tool Collection for nvcc. Giving nvcc directory I get an error: No compiler sets were found in the directory /usr/local/cuda/bin

What can be wrong with this setting? Is it probably permissions question? The nvcc file is there. The owner is root. netbeans file owner is user. I tried to change owner but I got the same error.

Thanks,

Roman

My company has made a plugin available that makes NetBeans 6.9.1 aware of the CUDA compiler under Linux. It is free and should hopefully solve your problems. You can find it by searching for “cuda” at the NetBeans Plugin Portal or from our website.

Hi jux,

I have downloaded and tryied te plugin you talk about and i think is great but I’m not able to compile my code, don’t know the reason.

I think is an error on my linking setup but i’m not able to fix it. The error that i receive wheni try to compile is that the cutil.h doesn’t exists.

I’m a complete beginner with CUDA so any help would be appreciated. I’m able to compile directly from console without any problem.

Thanks in advance.

[font=“arial, verdana, tahoma, sans-serif”]@jux

Any support for [/font][font=“arial, verdana, tahoma, sans-serif”]Mac OS X version 10.6.8 | Netbeans7.1 ? [/font][font=“arial, verdana, tahoma, sans-serif”] [/font]plugin[font=“arial, verdana, tahoma, sans-serif”] [/font]

[font=“arial, verdana, tahoma, sans-serif”]

Cheers

N[/font][font=“arial, verdana, tahoma, sans-serif”] [/font]