Can not connect to Jupyer notebook running in container of host machine from Remote machine

I am following this Link

I have host machine with GPU Tesla K10 on which I am performing commands in the links. I ran the docker in this machine.

I am remotely accessing this host machine from my laptop.

Problem: When I run the command :
docker run --gpus all -it -v “/path/to/dir/on/host”:"/path/to/dir/in/docker" -p 80:8888 nvcr.io/nvidia/tlt-streamanalytics:v2.0_py3 /bin/bash

I get below error:
Resolving ngc.nvidia.com (ngc.nvidia.com)… failed: Temporary failure in name resolution.
wget: unable to resolve host address ‘ngc.nvidia.com

Using mount folder I moved folder “gtcfallngcdemo:1.0.0” to docker workspace.

I started Jupyer notebook using command:
jupyter notebook --ip 0.0.0.0 --port 8888 --allow-root

But I can not access this notebook from remote machine which is my laptop. I use IP of host machine (not docker) in my laptop browser to access notebook. GPU machine with Docker running and my Laptop are in same local network.

Please help.

Mitesh

Hi @miteshp.patel, thank you for your question!

Looks like you have two issues here -

  1. Running the TLT container:
    Can you please share a screenshot of the error you’re receiving? Docker containers would ideally not run into a wget error - this might be an error when you’re trying to pull the resource with the command
ngc registry resource download-version "nvidia/gtcfallngcdemo:1.0.0"
  1. Accessing the Jupyter notebook:
    You may need to configure port forwarding from your host machine in order to be able to access Jupyter notebooks running on it from a web browser on your laptop.

Please refer to articles such as this for more guidance on how to configure port forwarding.

Hey. Thanks for your reply.

I was doing right everything. Only problem was I was accessing jupyter notebook with “hostIP:8888” which is wrong.

I tried with hostIP:80 and it worked. I searched for exact notation 80:8888.

Thanks.