Can not flash 4G nano,please help, thanks

I got two nano module, 4G & 8G

  1. use a shell script flash 8G succesfully.
  2. use the same cmd to flash 4G module, but failed.
    error: Top caller module: MSS, error module: MSS, reason: 0x12, aux_info: 0x01
    flash_orin_nx-qskj-20230914173221.log (233.7 KB)
    flash_orin_serialLog.txt (24.9 KB)
    I want to know how can i modify cmd scritp to flash it

thanks

Error Log:
[0048.540] I> MB1 (version: 1.2.0.0-t234-54845784-562369e5)
[0048.545] I> t234-A01-1-Silicon (0x12347) Prod
[0048.549] I> Boot-mode : Coldboot
[0048.552] I> Entry timestamp: 0x00000000
[0048.556] I> last_boot_error: 0x0
[0048.559] I> BR-BCT: preprod_dev_sign: 0
[0048.563] I> rst_source: 0xb, rst_level: 0x1
[0048.567] I> Task: SE error check
[0048.570] I> Task: Bootchain select WAR set
[0048.574] I> Task: Enable SLCG
[0048.577] I> Task: CRC check
[0048.580] I> Task: Initialize MB2 params
[0048.584] I> MB2-params @ 0x40060000
[0048.588] I> Task: Crypto init
[0048.591] I> Task: Perform MB1 KAT tests
[0048.595] I> Task: NVRNG health check
[0048.598] I> NVRNG: Health check success
[0048.602] I> Task: MSS Bandwidth limiter settings for iGPU clients
[0048.608] I> Task: Enabling and initialization of Bandwidth limiter
[0048.614] I> No request to configure MBWT settings for any PC!
[0048.620] I> Task: Secure debug controls
[0048.624] I> Task: strap war set
[0048.627] I> Task: Initialize SOC Therm
[0048.630] I> Task: Program NV master stream id
[0048.635] I> Task: Verify boot mode
[0048.640] I> Task: Alias fuses
[0048.644] W> FUSE_ALIAS: Fuse alias on production fused part is not supported.
[0048.651] I> Task: Print SKU type
[0048.654] I> FUSE_OPT_CCPLEX_CLUSTER_DISABLE = 0x000001c8
[0048.659] I> FUSE_OPT_GPC_DISABLE = 0x00000002
[0048.664] I> FUSE_OPT_TPC_DISABLE = 0x000000fc
[0048.668] I> FUSE_OPT_DLA_DISABLE = 0x00000003
[0048.672] I> FUSE_OPT_PVA_DISABLE = 0x00000001
[0048.677] I> FUSE_OPT_NVENC_DISABLE = 0x00000001
[0048.681] I> FUSE_OPT_NVDEC_DISABLE = 0x00000000
[0048.685] I> FUSE_OPT_FSI_DISABLE = 0x00000001
[0048.690] I> FUSE_OPT_EMC_DISABLE = 0x0000000c
[0048.694] I> FUSE_BOOTROM_PATCH_VERSION = 0x7
[0048.698] I> FUSE_PSCROM_PATCH_VERSION = 0x7
[0048.702] I> FUSE_OPT_ADC_CAL_FUSE_REV = 0x2
[0048.706] I> FUSE_SKU_INFO_0 = 0xd6
[0048.710] I> FUSE_OPT_SAMPLE_TYPE_0 = 0x3 PS
[0048.714] I> FUSE_PACKAGE_INFO_0 = 0x2
[0048.718] I> SKU: Prod
[0048.720] I> Task: Boost clocks
[0048.723] I> Initializing PLLC2 for AXI_CBB.
[0048.727] I> AXI_CBB : src = 35, divisor = 0
[0048.731] I> Task: Voltage monitor
[0048.734] I> VMON: Vmon re-calibration and fine tuning done
[0048.740] I> Task: UPHY init
[0048.745] I> HSIO UPHY init done
[0048.748] W> Skipping GBE UPHY config
[0048.751] I> Task: Boot device init
[0048.755] I> Boot_device: RCM
[0048.758] I> USB configuration success
[0048.761] I> Task: TSC init
[0048.764] I> Task: Load membct
[0048.767] I> RAM_CODE 0x4000041
[0048.770] I> Loading MEMBCT
[0048.773] I> Slot: 0
[0048.775] I> Binary[1] block-0 (partition size: 0x40000)
[0048.780] I> Binary name: MEM-BCT-1
[0048.783] I> Size of crypto header is 8192
[0048.787] I> Size of crypto header is 8192
[0048.791] I> BCH of MEM-BCT-1 read from storage
[0048.796] I> BCH address is : 0x40050000
[0048.800] I> MEM-BCT-1 header integrity check is success
[0048.805] I> Binary magic in BCH component 0 is MEM1
[0048.810] I> component binary type is 1
[0048.820] I> MEM-BCT-1 binary is read from storage
[0048.825] I> MEM-BCT-1 binary integrity check is success
[0048.830] I> Binary MEM-BCT-1 loaded successfully at 0x40040000 (0xe580)
[0048.836] I> RAM_CODE 0x4000041
[0048.842] I> RAM_CODE 0x4000041
[0048.845] I> Task: Load Page retirement list
[0048.850] I> Task: SDRAM params override
[0048.853] I> Task: Save mem-bct info
[0048.857] I> Task: Carveout allocate
[0048.860] I> Update CCPLEX IST carveout from MB1-BCT
[0048.865] I> ECC region[0]: Start:0x0, End:0x0
[0048.869] I> ECC region[1]: Start:0x0, End:0x0
[0048.874] I> ECC region[2]: Start:0x0, End:0x0
[0048.878] I> ECC region[3]: Start:0x0, End:0x0
[0048.882] I> ECC region[4]: Start:0x0, End:0x0
[0048.886] I> Non-ECC region[0]: Start:0x80000000, End:0x180000000
[0048.892] I> Non-ECC region[1]: Start:0x0, End:0x0
[0048.897] I> Non-ECC region[2]: Start:0x0, End:0x0
[0048.902] I> Non-ECC region[3]: Start:0x0, End:0x0
[0048.906] I> Non-ECC region[4]: Start:0x0, End:0x0
[0048.917] I> allocated(CO:43) base:0x17c000000 size:0x4000000 align: 0x200000
[0048.924] I> allocated(CO:39) base:0x179e00000 size:0x2200000 align: 0x10000
[0048.931] I> allocated(CO:20) base:0x176000000 size:0x2000000 align: 0x2000000
[0048.938] I> allocated(CO:24) base:0x174000000 size:0x2000000 align: 0x2000000
[0048.945] I> allocated(CO:28) base:0x172000000 size:0x2000000 align: 0x2000000
[0048.952] I> allocated(CO:22) base:0x178000000 size:0x1000000 align: 0x1000000
[0048.959] I> allocated(CO:35) base:0x179000000 size:0xe00000 align: 0x10000
[0048.966] I> allocated(CO:02) base:0x171800000 size:0x800000 align: 0x800000
[0048.973] I> allocated(CO:03) base:0x171000000 size:0x800000 align: 0x800000
[0048.980] I> allocated(CO:06) base:0x170800000 size:0x800000 align: 0x800000
[0048.987] I> allocated(CO:56) base:0x170000000 size:0x800000 align: 0x200000
[0048.994] I> allocated(CO:07) base:0x16fc00000 size:0x400000 align: 0x400000
[0049.001] I> allocated(CO:33) base:0x16f800000 size:0x400000 align: 0x200000
[0049.008] I> allocated(CO:23) base:0x16f600000 size:0x200000 align: 0x200000
[0049.015] I> allocated(CO:01) base:0x16f500000 size:0x100000 align: 0x100000
[0049.022] I> allocated(CO:04) base:0x16f400000 size:0x100000 align: 0x100000
[0049.029] I> allocated(CO:05) base:0x16f300000 size:0x100000 align: 0x100000
[0049.036] I> allocated(CO:08) base:0x16f200000 size:0x100000 align: 0x100000
[0049.043] I> allocated(CO:09) base:0x16f100000 size:0x100000 align: 0x100000
[0049.050] I> allocated(CO:15) base:0x16f000000 size:0x100000 align: 0x100000
[0049.057] I> allocated(CO:17) base:0x16ef00000 size:0x100000 align: 0x100000
[0049.064] I> allocated(CO:27) base:0x16ee00000 size:0x100000 align: 0x100000
[0049.070] I> allocated(CO:42) base:0x16ed00000 size:0x100000 align: 0x100000
[0049.077] I> allocated(CO:54) base:0x16ec80000 size:0x80000 align: 0x80000
[0049.084] I> allocated(CO:34) base:0x16ec70000 size:0x10000 align: 0x10000
[0049.091] I> allocated(CO:72) base:0x16ea70000 size:0x200000 align: 0x10000
[0049.098] I> allocated(CO:46) base:0x140000000 size:0x20000000 align: 0x20000000
[0049.105] I> allocated(CO:47) base:0x16e600000 size:0x400000 align: 0x200000
[0049.112] I> allocated(CO:48) base:0x16ea50000 size:0x20000 align: 0x10000
[0049.119] I> allocated(CO:69) base:0x16ea30000 size:0x20000 align: 0x10000
[0049.126] I> allocated(CO:49) base:0x16ea20000 size:0x10000 align: 0x10000
[0049.132] I> allocated(CO:50) base:0x16ea10000 size:0x10000 align: 0x10000
[0049.139] I> NSDRAM base: 0x80000000, end: 0x16ea70000, size: 0xeea70000
[0049.146] I> Task: Thermal check
[0049.149] I> max_chip_limit = 105
[0049.152] I> min_chip_limit = -28
[0049.155] I> max temp read = 29
[0049.158] I> min temp read = 28
[0049.161] I> Task: Update FSI SCR with thermal fuse data
[0049.166] I> Task: Enable WDT 5th expiry
[0049.170] I> Task: I2C register
[0049.173] I> Task: Set I2C bus freq
[0049.176] I> Task: Reset FSI
[0049.179] I> Task: Pinmux init
[0049.182] I> skipped mmio_addr = 0x9240008
[0049.186] I> skipped mmio_addr = 0x9240000
[0049.190] I> skipped mmio_addr = 0x9240010
[0049.194] I> skipped mmio_addr = 0x9240018
[0049.198] I> skipped mmio_addr = 0x9240020
[0049.202] I> skipped mmio_addr = 0x9240030
[0049.206] I> skipped mmio_addr = 0x9240028
[0049.210] I> skipped mmio_addr = 0x9240038
[0049.214] I> skipped mmio_addr = 0x9240040
[0049.218] I> skipped mmio_addr = 0x9240048
[0049.222] I> skipped mmio_addr = 0x9241000
[0049.226] I> skipped mmio_addr = 0x9241008
[0049.230] I> skipped mmio_addr = 0x9241010
[0049.233] I> skipped mmio_addr = 0x9241018
[0049.237] I> skipped mmio_addr = 0x9241020
[0049.241] I> skipped mmio_addr = 0x9241028
[0049.245] I> skipped mmio_addr = 0x9241030
[0049.249] I> skipped mmio_addr = 0x9241038
[0049.253] I> skipped mmio_addr = 0x9241040
[0049.257] I> skipped mmio_addr = 0x9242000
[0049.261] I> skipped mmio_addr = 0x9242008
[0049.265] I> Task: Prod config init
[0049.268] I> Task: Pad voltage init
[0049.272] I> Task: Prod init
[0049.274] I> Task: Program rst req config reg
[0049.279] I> Task: Common rail init
[0049.282] I> DONE: Thermal config
[0049.286] W> DEVICE_PROD: module = 13, instance = 4 not found in device prod.
[0049.295] I> DONE: SOC rail config
[0049.298] W> PMIC_CONFIG: Rail: MEMIO rail config not found in MB1 BCT.
[0049.305] I> DONE: MEMIO rail config
[0049.309] W> PMIC_CONFIG: Rail: GPU rail info not found in MB1 BCT.
[0049.315] I> DONE: GPU rail info
[0049.318] W> PMIC_CONFIG: Rail: CV rail info not found in MB1 BCT.
[0049.324] I> DONE: CV rail info
[0049.327] I> Task: Mem clock src
[0049.330] I> Task: Misc. board config
[0049.334] I> PMIC_CONFIG: Platform config not found in MB1 BCT.
[0049.339] I> Task: SDRAM init
[0049.342] I> MemoryType: 4 MemBctRevision: 1
[0049.349] I> MSS CAR: PLLM/HUB programming for MemoryType: 4 and MemBctRevision: 1
[0049.356] I> MSS CAR: Init PLLM
[0049.359] I> MSS CAR: Init PLLHUB
[0049.364] I> Encryption: MTS: en, TX: en, VPR: en, GSC: en
[0049.404] E> MSS: Failed to initialize SDRAM.
[0049.408] C> Task 0x2f failed (err: 0x48480112)
[0049.412] E> Top caller module: MSS, error module: MSS, reason: 0x12, aux_info: 0x01
[0049.420] C> Boot Info Table status dump :
01111111001110001111111111111111111111111111101

You can try to clarify what is “same cmd” first…

thanks for reply.
I use two cmds, both failed when flash 4G module:
1)sudo ./flash.sh --no-systemimg -c bootloader/t186ref/cfg/flash_t234_qspi.xml qskj-orin-nx-dev internal
2)sudo ./tools/kernel_flash/l4t_initrd_flash.sh -S 118GiB --external-device nvme0n1p1
-c tools/kernel_flash/flash_l4t_external.xml -p “-c bootloader/t186ref/cfg/flash_t234_qspi.xml”
–showlogs --network usb0 qskj-orin-nx-dev internal

attachment is qskj-orin-nx-dev.conf
qskj-orin-nx-dev.conf (3.9 KB)

What is the jetpack release in use here?

latest version: 35.4.1

Please also share full host side log.

And only need to try initrd flash command. No need to try flash.sh.

Do you have orin nano devkit on your side?

full host side log had upload top with time.

I had a plink C11 board now, and can use it to flash now.

Please also share your successful flash host and uart log on that plink board. BTW, I mean orin nano 4gb case. Not 8gb.

For I had create the img to flash, so just running cmd:

  1. swith to root user

  2. ./tools/kernel_flash/l4t_initrd_flash.sh --flash-only --external-device nvme0n1p1
    -c tools/kernel_flash/flash_l4t_external.xml -p “-c bootloader/t186ref/cfg/flash_t234_qspi.xml”
    –showlogs --network usb0 qskj-orin-nx-dev internal
    module can not reboot successfully, and report the same error log now.

  3. the log I mentioned is 4G failed log, include host & uart log.

  4. I tried again with 8G module, it happened the same error with 4G module now.

here is the 8G module flash successful log.
flash_orin_nx-qskj-20230914170226.log (267.7 KB)

Hi,

幾個問題, 我這邊也用中文說明一下以免前面沒弄清楚

  1. 請問你這個問題是不是一定得用–flash-only才能打到? 我的意思是Orin Nano 8GB 的image不能直接用在Orin Nano 4GB的module上

  2. Orin 8GB module的log沒有太大的幫助. 我只想請問你那邊到底有沒有任何一個case可以讓Orin Nano 4GB flash成功?


Few questions to clarify

  1. Does this issue have to be reproduced with “–flash-only” parameter? I mean Orin Nano 8GB image cannot be used to Orin Nano 4gb directly.

  2. You don’t need to share the log of 8GB module. I only want to ask do you have any successful flash and boot case on 4GB module on your side?

  1. orin nano 8G 的哪些image与nano 4G的不通用? 之前plink告诉我说与orin nx都是通用的
    flash-only和full flash一样都会出现
  2. 4G module第一次拿到,就一个,都不成功

Hi,

通用的意思只有說"orin-nano-devkit.conf"這個檔案可以燒所有的orin nano/nx.
但你沒辦法先 “–no-flash” 建出一個orin 8gb image然後又拿去給4gb module燒錄

4G module第一次拿到,就一个,都不成功

所以你也沒有除了plink以外的底版的測試嗎?

已经用no-flash使用.conf创建Image进行了测试, 但是仍然有一样的错误

I can use no-flash to create a Image for 4G module, and had tried.
but happened the same error

請問現在是要說中文比較清楚還是要用英文?

我前面的意思就是你不能用–no-flash.

我现在就一个plink的底板,除了用no-flash,还可以用什么命令刷机么?

sudo ./tools/kernel_flash/l4t_initrd_flash.sh -S 118GiB --external-device nvme0n1p1
-c tools/kernel_flash/flash_l4t_external.xml -p “-c bootloader/t186ref/cfg/flash_t234_qspi.xml”
–showlogs --network usb0 qskj-orin-nx-dev internal

你前面這個, -S拿掉 先不要加那個.

好,我再试试
这个命令我们用来烧写Orin NX是正常的

仍然是一样的问题,从log来看,就是重启的时候,MB1启动失败了

这样是模块有损坏么?

Hi,

基本上我們這裡所有的測試項目都得在NV devkit上面測試才能決定是不是真的是module損壞

如果你沒有devkit驗證, 請你聯絡Plink跟他們反應這個問題.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.