Can not flash nx on WSL2 with Win11

Hi:
I want to flash nx on wsl2-ubuntu20 witch win11.Because the WSL cannot reconnect to the USB, the burning fails.
I refer to the documentation from Windows Subsystem for Linux.

Here’s how I do it

  1. Boot the Jetson device into Recovery mode. Connect the Jetson device to a USB port on Windows machine.

2.Attach the BUS ID to the WSL Linux distribution.

3.Flash NX
wsl——2

sudo ./tools/kernel_flash/l4t_initrd_flash.sh --flash-only --external-device nvme0n1 -c ./tools/kernel_flash/flash_l4t_nvme.xml -S 100GiB --showlogs jetson-xavier-nx-devkit-emmc nvme0n1p1

Then the flash fails
image

The reason for the failure is that the USB is not reconnecting to the WSL.


But I’ve set up the USB reconnection in win11.

usbipd attach --busid 2-7 --auto-attach --wsl Ubuntu-20.04

How do I fix this?

l4t_initrd_flash.sh is not supported in WSL afaik. flash.sh does work.

You need this:

xavier nx 8GB, jetpack 5.1.3,L4T 35.5.0

你真的有看我貼的東西嗎…

Q: How to flash external storage devices with WSL2?

For flashing eMMC/SD card with flash.sh, the default setting of WSL2 will work fine.

However, if you are trying to use initrd flash to flash NVMe/USB, please refer to the following post to re-build the Linux kernel with a customized kernel config, as the default kernel of WSL2 shipped by Microsoft lacks some functionalities that are required for initrd flash to work.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.