Can not install cuda anymore

Hi,

NVIDIA installer failed, windows7 and now windows 10

I have VS2017 but seems that from the log it only checks for VS2012,VS2013 and VS2015, what is going on?

DEBUG: [CUDAVisualStudioIntegration.CUDAVisualStudioIntegrationExtSite] 620@CCUDAVisualStudioIntegrationExtSite::DetectVSInstallations : VS2012InstallDir  set to  . 
     85.036 |    DEBUG: [CUDAVisualStudioIntegration.CUDAVisualStudioIntegrationExtSite] 621@CCUDAVisualStudioIntegrationExtSite::DetectVSInstallations : VS2013InstallDir  set to  C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\IDE\. 
     85.036 |    DEBUG: [CUDAVisualStudioIntegration.CUDAVisualStudioIntegrationExtSite] 622@CCUDAVisualStudioIntegrationExtSite::DetectVSInstallations : VS2015InstallDir  set to  C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\. 
     85.039 |    ERROR: [CUDAVisualStudioIntegration.CUDAVisualStudioIntegrationExtSite] 842@CCUDAVisualStudioIntegrationExtSite::RetrieveInstallDataFormNames : COM error: Exception {0x80070002 - The system cannot find the file specified.; File: CUDAVisualStudioIntegrationExtSite.cpp; Line: 1281}. 
     85.036 |    ERROR: [NVI2.InstallThread] 54@CInstallThread::ThreadProc : Install failed - Exception {0x80070002 - The system cannot find the file specified.; File: InstallationStepper.cpp; Line: 2072} - going to fail state.

Why it does not check for VS2017?

85.035 |  WARNING: [CUDAToolkit.CUDAToolkitExtSite] 811@CCUDAToolkitExtSite::IsOSSupported : CUDA is not supported on the current OS version 10.0.17134.

Is completely gone mad!

I attached the complete log.

Log.8052setup.exe.log (4.38 MB)

What CUDA version are you trying to install? Per the Windows support matrix MSVS 2017 is supported by CUDA 10.1:

https://docs.nvidia.com/cuda/cuda-installation-guide-microsoft-windows/index.html

Is your MSVS 2017 installation partially corrupted by any chance? Is this a clean install of CUDA or are there possibly older versions of CUDA on this machine that could interfere? E.g. you think you are running the CUDA 10.1 integration script, but are actually running the script from an older version.

Hi,

Cuda 10.1 for windows 10 and no, MSVS 2017 is not corrupted.

I checked everything from installation guide to other people having similar issue.

The installation just has gone mad, I can not install cuda 10.1 or cuda 10 and the log does not say much.

Furthermore, you can have other installation of cuda like I had before, but now I tried everything from restalling the driver to uninstalling everything.

Yes, you can have multiple version of CUDA installed on a machine. However, only one can be integrated with MSVS, as far as I know.

The reason I was asking questions is because the typical scenario leading to observations like yours is this:

Something goes wrong with installation, or user performs (for whatever reason) only a partial installation. User tries installing a second time. User tries installing N different versions of the software. User tries uninstalling some version(s). User furiously tries whatever they can think of in terms of re-installing, un-installing, configuration settings etc.

At this point there is a wild hodgepodge of bits on their storage device. They ask for help on a forum. Nobody not sitting in front of user’s machine knows what that hodgepodge of bits looks like and how to straighten it out.

I would suggest going back to a clean slate (maybe a restore point), with no version of MSVS and no version of CUDA present on the machine. Install MSVS 2017. Install CUDA 10.1.

Thanks, but I was wondering, what is the point of the installation log file? I was hoping that someone from NVIDIA would have a look at it.

I don’t know why there is a log file. Presumably it is there to ease debugging should there is a bug in the installer.

A model in which NVIDIA would make people available for analyzing installation logs every time someone’s install blows up simply does not scale. If you are lucky someone from NVIDIA will look at this thread and may have some wisdom to dispense. Generally speaking these developer forums were set up as a platform for users helping users, and not very many NVIDIA employees are active in the forums. The amount of technical involvement demonstrated by Robert Crovella is unusually high compared to the historical average.

Just to be clear, I have been (more than once) that guy whose installation of some software blew up and who frantically tried all kind of steps to fix it, but only managed to make a bigger mess in the process. I know how frustrating it can be. The conclusion I have drawn from my past experience is that starting with a clean slate is the way to go, and my butt was saved on more than one occasion by a suitable Windows restore point.

Well, I solved the issue by removing visual studio 2017.