Can not make the Deepstream python binding in DS-6.3

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU) : GPU
• DeepStream Version :6.3
• NVIDIA GPU Driver Version (valid for GPU only) : 525.125.06
• Issue Type( questions, new requirements, bugs) : Question
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

I am following the documentation as provided in:

When i followed the steps, i had an error at the make step in below script:

cd deepstream_python_apps/bindings
mkdir build
cd build
cmake …
make -j$(nproc) **

The error is
Scanning dependencies of target pyds [ 6%] Building CXX object CMakeFiles/pyds.dir/src/bindtrackermeta.cpp.o [ 31%] Building CXX object CMakeFiles/pyds.dir/src/bindanalyticsmeta.cpp.o [ 43%] Building CXX object CMakeFiles/pyds.dir/src/custom_binding/bindcustom.cpp.o [ 43%] Building CXX object CMakeFiles/pyds.dir/src/pyds.cpp.o [ 43%] Building CXX object CMakeFiles/pyds.dir/src/bindfunctions.cpp.o [ 43%] Building CXX object CMakeFiles/pyds.dir/src/bindgstnvdsmeta.cpp.o [ 50%] Building CXX object CMakeFiles/pyds.dir/src/bindmeta360.cpp.o [ 37%] Building CXX object CMakeFiles/pyds.dir/src/utils.cpp.o [ 56%] Building CXX object CMakeFiles/pyds.dir/src/bindnvbufsurface.cpp.o [ 62%] Building CXX object CMakeFiles/pyds.dir/src/bindnvdsmeta.cpp.o [ 68%] Building CXX object CMakeFiles/pyds.dir/src/bindnvosd.cpp.o [ 75%] Building CXX object CMakeFiles/pyds.dir/src/bindopticalflow.cpp.o [ 81%] Building CXX object CMakeFiles/pyds.dir/src/bindschema.cpp.o [ 87%] Building CXX object CMakeFiles/pyds.dir/src/bindnvdsinfer.cpp.o In file included from /opt/nvidia/deepstream/deepstream-6.3/sources/deepstream_python_apps/bindings/src/utils.cpp:26: /opt/nvidia/deepstream/deepstream/sources/includes/gstnvdsmeta.h:43:10: fatal error: gst/video/video.h: No such file or directory 43 | #include <gst/video/video.h> | ^~~~~~~~~~~~~~~~~~~ compilation terminated.
When i tried to search the issue in platform i found this step Unable to run deepstream_python _apps (and others...) - #8 by Amycao

But this solution couldnt help as well.

I didnt encounter this problem with Deepstream version 6.2 but has this issue in 6.3. I need version 6.3 because i need to use my custom onnx model for deepsort tracker.

Can you please help me on this?? It’s a little urgent! Sorry for the inconvenience.


This error means gstreamer is not installed successfully.

Can the native deepstream-test1 run normally ?

Noticed you use dGPU, you can try run in /opt/nvidia/deepstream/deepstream to install python bindings.

In the directory you mentioned, there is no such file.

Here is the list of files in opt/nvidia/deepstream/deepstream


Do you run DeepStream on GPU ?

if does not exist, I think you need reinstall deepstream first

I am running it in the docker. The docker image i am using is

Isnt the file part of the docker image??

Try this images.

I use it too.

I tried to run the native deepstream app by using the Makefile and specifying the version of cuda.
I got the following error. So i think gstreamer is not installed.
deepstream_app.c:23:10: fatal error: gst/gst.h: No such file or directory
23 | include <gst/gst.h>
| ^~~~~~~~~~~
compilation terminated.

I will try with the image that you mentioned.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.