Can not play video with command gst-play-1.0 with dhua camera?

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU) Jetson
• DeepStream Version 5.2
• JetPack Version (valid for Jetson only) 4.4
• TensorRT Version 7.1.3
• NVIDIA GPU Driver Version (valid for GPU only)
• Issue Type( questions, new requirements, bugs) questions
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

I have one dhua camera with rtsp url is “rtsp://admin:password@10.10.10.10:554/cam/realmonitor?channel=1&subtype=0”.
I can play video with opencv codes with CPU decode, but failed when use command [gst-play-1.0 “rtsp://admin:password@10.10.10.10:554/cam/realmonitor?channel=1&subtype=0”].

Below is the command output:
Press ‘k’ to see a list of keyboard shortcuts.
Now playing rtsp://admin:password@10.10.10.10:554/cam/realmonitor?channel=1&subtype=0
Pipeline is live.
ERROR Could not read from resource. for rtsp://admin:password@10.10.10.10:554/cam/realmonitor?channel=1&subtype=0
ERROR debug information: gstrtspsrc.c(5917):gst_rtsp_src_receive_response():/GstPlayBin:playbin/GstURIDecodeBin:uridecodebin0/GstRTSPSrc:source:
Could not receive message.(Timeout while waiting for server response)
Reached end of play list.

There is no update from you for a period, assuming this is not an issue anymore.
Hence we are closing this topic. If need further support, please open a new one.
Thanks

The app does not find valid rtsp data from the rtsp source(the camera), please check your camera first.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.