Can only see half a stretched screen (as if it's double height) on 337.12

How you are changing resolution and refreshrate? From nvidia-settings or xbmc or anything else?

Both xrandr and nvidia-settings elicit the same breakage. Again, I don’t think userspace is the problem here.

We tried the user scenarios,But still we don’t have repro.

As per our understanding from the users comment in forum the below users who reported the issue are using the same model SAMSUNG 3D TV or a bit higher version of same series.

OliWarner : Samsung UE46F6100

nvbenutzer : Samsung UE40F6100

TomLoeffel : Samsung UE46F6100

I hope we tried all reported users repro scenarios and the only thing we don’t tried is with the reported model of SAMSUNG TV, Which we don’t have to try.

From the above It looks clearly a monitor specific issue.

I think we can’t help on Bug 1512542 this issue as we don’t have Samsung UE46F6100, TV LED 46’', Full HD, 3D

I am sure that’s a fact and as a developer, I would state the same.
But why did it work in the old driver version 304 then? What has been changed in the way of telling the screen its resolution and refreshrate?
How can we - the users - deliver helpful information for a bugfix?

Edit: Found a workaround here on
Maybe it is a helpful hint for the nvidia developers?

I have the same issue also with a samsung TV of the F6100 series.
My set up:

Samsung UE46F6100
Zotac HD-ID40

Got the problem when I try to run latest Gotham version of Openelec or Xbmcbuntu.
When I use and older Frodo build then it works

Don’t suppose you have a valid EDID file for a Samsung full-HD screen that you could share with a brother in arms? I think you have my email address already.

My only other Samsung screens are 1920×1200 so I suspect theirs won’t work.

I think it would be better to share my walkthrough so that other people can reproduce the way:

  1. Download the log file for a Samsung Syncmaster FullHD from here:

  2. According to the directions on I created the edid.bin file with the following command:

nvidia-xconfig --extract-edids-from-file=<LOGFILE> --extract-edids-output-file=<TARGETPATH>/edid.bin

is the file from (1.) and is where you’d like it to be stored.

  1. Create and/or modify your /etc/X11/xorg.conf file so that it matches the file from

Attention: DFP-0 might be some other display on your machine, for example DFP-1 like it has been on my computer. Also the path to edid.bin has to be adjusted.

  1. Reboot and be happy (for now).

Hi there again.

I thought about this lately, if it could be useful for the developers to reproduce this “the other way around”:

We provide all our EDID.bin files and the developers could try to force their NON-F6100 series screen to be stretched. Would that work?