Can running multiple CUDA apps in X cause hang?

I am burning in a new system that has 2 x 8800GT cards (Kubuntu 7.10, nvidia driver 169.09) on a Gigabyte board with 2 x PCIe 2.0 slots. I have had no general problems overall. One night, I ran the (release) MonteCarloMultiGPU app in a tight script loop (to exercise both video cards under CUDA) and the system was fine the next morning, still obligingly churning out the answers.

Last night, I ran that loop in a console, and in addition, had the ‘nbody’ CUDA/OpenGL app running in a graphical window at the same time. When I checked this morning, the machine was totally unresponsive, nothing on the display (and couldn’t switch to console mode, ex. using Alt-Ctrl-F1 etc.) – I had to do a hard reset to get the system going again.

Would have running these two things at the same time have created a situation that might be expected to cause a system lockup? That is ok, but I’d like to know, so that I am not suspicious of faulty hardware.

fyi, I am using all top-quality components (Intel E8400 CPU at stock speed, G-Skill RAM, Antec SLI-certified power supply, etc.)


Well, if you run a program that launches a lot of kernels per second constantly, X can hang or become really unresponsive as it seems CUDA takes priority to graphics updates. But this should stop as soon as the program is finished…

There should never be OS level instability, however if you’re over-taxing your hardware, its possible that X will appear hung, much as wumpus suggested.

Did you attempt to ping or ssh to the system when the local console was hung?

If this hang is reproducible, you should verify that you’re using the latest motherboard BIOS, and setup a serial or net console to capture any kernel messages. You should also generate and attach an nvidia-bug-report.log.