Can someone please confirm oclBandwidthTest works with Fermi (Tesla C2050)?

I’m using
and while oclDeviceQuery works, oclBandwidthTest gave the error “Failed to create OpenCL context!”.

Thanks. Andrew

OpenCL and Fermi seems to be a problem. The minimum release Linux driver with proper Fermi support is 195.36.24, and that driver package ships without OpenCL support. The only driver package with both Fermi support and OpenCL is the 256.25 beta driver which was released last week. I haven’t yet tried it.

How do you know that linux driver version 195.36.24 does not ship with OpenCL support?

I recently loaded Ubuntu 10.4. After reboot, I got notification of an nVidia driver that was available. I installed it. It turned out to be 195.36.15. The OpenCL program I tried ran. I was running a GTX 480, not a Tesla C2050. I did not stay there long, switched to 256.22

Because there is no in the driver package.

195.36.15 (the CUDA 3.0 release drvier) mostly works with Fermi, but there are some weird things going on, in CUDA at least. The 195.36.24 package is the first driver with “official” Fermi support, I think.

Thanks I’ll check out a newer driver when I have a moment.

OK, the 256 beta ( plus the support libs listed below, appears to work with OpenCL + Fermi on Linux (where by “work” I mean oclDeviceQuery and oclBandwidthTest and oclVectorAdd) all return OK, and I’m using a C2050 on CentOS 5.4.



It’s not 100% reliable, though.