Can Ubuntu OS be ran from USB instead of microSD?

For me actual transfer rate for MicroSD is up to 727mbps, and for USB up to 3gbps (5gpbs is theoretical limit but it is usually not achievable in practice). The difference is not noticeable for most everyday tasks, but if using swap or other workloads bound by disk speed, using USB SSD is worth it, since it is few times faster (and in some specific workloads it can be even more than order of magnitude faster).

By the way, I have some bad MicroSD cards which cannot exceed 80-90mbps and it indeed may take a while to flash them and bad cards may make the system feel slower than with HDD. If it takes entire night to flash and install 3 MicroSD cards, they are not good for Jetson Nano. High quality MicroSD cards are much faster and their data rate can exceed 700mbps.

I think even 700mbps will not suffice for the applications to run. I’m planning to run Pytorch and other AI applications, and they are data intensive will need fast data transmission. Also the way that MicroSD is mounted is not efficient for mount/dismount memories. I have a acrylic rack and have to screw in the kits, now I have to unscrew the kits and then put in the MicroSD cards, that’s just a lot of headache when I could have just plugged USB through the back.

I would like to know what brand and memory capacity your MicroSD is. The fastest MicroSD to date is up to 300mbps. The one I use is Micro SDXC 1TB class 10. Thank you.

Perhaps you read somewhere that fastest MicroSD to date are up to 300 MBps and misinterpreted it as 300 mbps (often written as Mbps, but MBps are never written as “mbps”)? Fastest MicroSD cards to date can be faster than 2gbps for both read and write operations. Still slower than USB 3 SSD which can go beyond 3gbps, and therefore come closer to USB 3.0 theoretical limit of 5gbps. Even my old SunDisk Extreme 128GB (class U3) is faster than 700mbps for reading and faster than 380mbps for writing (measured the speed by non-buffered reading and writing of 10GiB). But there is a catch - MicroSD are usually not as good as SSD when it comes to random IO in small blocks which often occurs when using swap, working with many small files and other similar workloads.

This is why I ended up using USB 3 SSD for swap and my home directory (where I have files which I use for Pytorch and other AI applications). I also disabled zram and enabled zswap with lz4 compressor. For me this noticeably improved performance in RAM and IO demanding tasks. I decided to keep the OS itself on MicroSD since it is fast enough and moving it to SSD is unlikely to improve real-world performance (at least, in my case) but would reduce available space on SSD. Of course with sufficiently large SSD or if MicroSD card is bad (or just not convenient to use for some reason) it may make sense to move everything to SSD.

By the way, Class 10 and 80mbps speed for 1TB MicroSD card sounds awful. Even few years ago a card with such speed was often not good enough. For example, few years ago I purchased an action camera capable of recording 4K, at first I tried to use it with a card capable of just 80-90mbps (this matched promised minimum guaranteed speed by Class 10 for sequential writing but turned out to be not good enough), I could not record video at highest quality (100mbps) so I had to buy a better card - it was already mentioned SanDisk Extreme 128GB card of U3 class, which I ended up using in Jetson Nano. So I doubt its speed is anything special… it is just fast enough for most tasks. For example, I do not remember exactly how fast I flashed it, but it was relatively fast, 10-20 minutes perhaps, including read verification. Installation did not took too long either.

As of today, fastest MicroSD are usually of speed class V90 (however some cards marked as U3 may achieve similar performance). Class 10 cards deprecated many years ago; even though they are still produced but their cheap price comes at the cost of very limited speed.

I bought myself 3 A2 class 64mb MicroSD, now it’s faster and usable, unlike before not usable at all. There’s still about 1 second lag time trying to bring up Chromium browser.
Now I have problem installing most of the softwares. I tried to install omniverse, I don’t know why Jetson Nano is such user unfriendly machine that don’t offer one click installation like Windows based PCs. I’m getting frustrated with all the command that I have to deal with. How do they expect people to learn AI when they are bogged down with commands and doesn’t install?

I do not think it makes sense to compare Windows based PC to Jetson Nano, and it is hard to understand such a comparison - for example, I have no idea what “one click installation” was supposed to mean. My experience is exactly the opposite, Windows to me feels very unfriendly where I literally have issues or even impossibility of installing and using most of the software I need, and getting something installed is never as simple as a single click, while in Ubuntu I can install most of software with a single command without being bogged down by GUI. This is why the comparison makes no sense at all, Windows and Ubuntu are too different.

It may make more sense to compare Ubuntu-based PC and Jetson Nano. This would allow to focus on issues which are specific to Jetson Nano instead of discussing differences between OSes and personal preferences. For example, I did encounter some difficulties even with getting 2.5K HDMI monitor working, and I had to learn how to patch and compile kernel, learning some new commands in the process. Or if I want to get latest fastai, I have to build latest pytorch which turned out to be slow and complicated process. Even getting mpv working with hardware acceleration wasn’t easy.

But I do not feel this as I am “bogged down with commands”, I see this as an opportunity to learn something new (when I use solutions already discovered by others) or as an opportunity to solve problems nobody solved yet. Besides, Jetson Nano is called development kit for a reason. When I tried first NVidia AI course, I was surprised how easy to get started. But of course I had to actually learn, not just copy and paste… For example, I wanted to use Ethernet camera instead of USB or MIPI, so to even get the very first example working I had to write my own code. On PC it would not be easier than that anyway so I cannot complain.

Besides, compared to other embedded platforms I have tried so far under $120, I liked Jetson Nano the most and overall I had much less issues with it and got the best performance for the price. It may be not perfect, but I think it is a good choice in terms of user-friendliness and performance if we compare it with other ARM64 development boards with in the same price range.

Anyway, sounds like the issue this topic was about is solved. If you have different issues and have a difficulty solving them, please create new topic per issue, and describe what you have tried and what you need to accomplish.

I need help. Can’t even load any chat program or screen capture program that can show what the error message is. Why is Jetson Nano so difficult?

I suggest to start a new topic about new issue. Include details what program you are trying to run, how you installed it, what error it shows (type the error message manually as text or take a photo as a last resort if you cannot take a screenshot).

it says “unable to install telegram desktop” “cannot perform the following tasks”, and then it would give no reason why.

I don’t know what this topic would fall under either, so I guess I’m SOL.

They should have in the installer package to have a chat and screen capture program included, but that’s just me. They probably think everyone is as technically adept as they are.

Actual operation is sort of a “Linux” thing, but keep in mind that an embedded system does not have a BIOS, and thus the entire boot setup is going to be unfriendly towards installing on almost any embedded hardware. Some embedded systems are obviously easier, but there tends to be some hardware tradeoffs and/or cost tradeoffs when doing so.

If you were to learn on a full PC running Linux, then you’d have some of the issues, but many of the issues would go away. You can learn on a Linux PC to save some of the effort. I by far prefer developing under Linux, I doubt I would ever go back to developing under Windows, but there is a learning curve.

Fine, now we got that out of the way, why can’t I install Telegram Desktop? It’s a chat client, doesn’t take up much space. I also can’t install screen capture programs. Need help if you can please thanks.

You did not describe exact steps you are using to install Telegram or “screen capture programs”, so it is hard to tell if your problem is reproducible or what’s wrong.

Even though I usually install everything from command line, each time I installed fresh OS on Jetson Nano, I usually click on Telegram Desktop to install it because it offers to install it after initial setup. It always just worked, and I have tried it on different SD cards and with different JetPack versions. So usually installing Telegram is very easy for everyone. If it does not work for you, then either you are doing something different or your environment is different. Environment is not just OS and files on Jetson Nano, it includes your internet connection as well, if it is not reliable, installation may fail even if you are doing the same steps and are using the same OS as I. There is also a chance that if something goes wrong in the middle of installation, it may stay screwed up and all subsequent attempts will fail too regardless of how good your Internet connection is. The point is, you should not assume that everyone has the same issues as you, others may have everything working out of the box and will have no idea what is wrong on your end and can only guess what you are doing unless you describe it.

Since whatever you are doing to install Telegram is not working for you, I suggest to run the following command in a terminal:

sudo snap install telegram-desktop

If you get errors, please copy and paste the terminal output including the command you ran and errors you’ve got.

It is even harder to guess what “screen capture programs” you are trying to install and how exactly you are trying to install them. Personally I prefer to use Spectacle for screenshots and ffmpeg for screencasts. If you want to just capture screenshots, you can install the app by running sudo apt install spectacle and then launch spectacle.

sorry this is what came up:

$ sudo snap install telegram-desktop
[sudo] password for pc1:
error: cannot perform the following tasks:

  • Mount snap “telegram-desktop” (2482) ([start snap-telegram\x2ddesktop-2482.mount] failed with exit status 1: Job for snap-telegram\x2ddesktop-2482.mount failed.
    See “systemctl status “snap-telegram\x2ddesktop-2482.mount”” and “journalctl -xe” for details.

very frustrating. that goes with most of the programs I try to install. Any help if can thank you.

This is what happens when I tried to install spectacles:

~$ sudo apt install spectacle
[sudo] password for pc1:
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package spectacle

This is unusual error, googling "Mount snap" "failed with exit status 1: Job for" "ubuntu" returned just 57 results at the time of writing (adding “jetson nano” brings down number of results to 1 to a site with probably irrelevant page which does not even open for me).

It looks like both apt and snap packaging systems are broken on your Jetson Nano. There are may be a way to repair your system but backing up your home folder and config files (if you have anything important) and fleshing fresh SD card image would be much faster. If after this the issue appears again, it may be worth to investigate it further.

If you want to investigate, first things to try would be to run sudo snap install telegram-desktop again and then check output of sudo systemctl status "snap-telegram\x2ddesktop-2482.mount" and journalctl -xe, this may give a clue why it fails. It feels like fuse (userspace filesystem) either is not working or is not installed, or something else is very wrong, but this is strange, it should be working out of the box.

And for your issue with apt, you could try sudo apt update first, then try to install something else, for example sudo apt install htop or sudo apt install ffmpeg, does it fail in the same way? If still does not work, then what is the content of /etc/apt/sources.list and output of cat /etc/apt/sources.list.d/* command?

But as I have said, if you are frustrated and want to get everything working as quick as possible, it would be easier to reflash and investigate only if the issues reoccur in fresh system. If it does, that would be very unusual - in this case please describe how you are installing fresh OS on Jetson Nano (by flashing SD card with Balena Etcher or flashing with sdk-manager, or some other method).

Sorry, you have no Idea how many times I have reflashed and reinstalled. The only thing I can think of is hardware failure, yet Chromium and LibreOffice software works, so I don’t really know what the problem is. All other installations don’t work. I’m beginning to think Jetson Nano is just a piece of crap when it’s supposed to be a super AI. Anyways I will give flashing one more try, and possibly send back these Jetson Nanos and Trade in for a Jetson Javier NX (I have 3 Jetson Nanos and trying to network them).

Does it need to be installed by “snap”? You can see it is available without snap:
apt-get search telegram-desktop

Perhaps:
sudo apt-get install telegram-desktop

There is no spectacle package at all for Ubuntu.

Maybe you should try: apt-get install kde-spectacle or snap install spectacle.

Beside this I think you should make you familair what Linux, ARM64 (AArch64) and “AI” on a Jetson means.

I feel you have very wrong expecations.