Can we stop the Wp64 warning from showing? Cuda 2.1 changes

First of all thanks for 2.1. There arent too many changes. Makes my life easier.
I have successfully migrated to Visual Studio 2008. :thumbup:

So far, there are 2 things that trouble me in 2.1 -

  1. How to detect that there is ‘no cuda hardware’. Check my other post for detailed description of this problem.
  2. How to stop the ‘Wp64 deprecated’ warning.

Whenever I build under 2.1 I get the following warning:
cl: option Wp64 has been deprecated and will be removed in future release

I HAVE removed the /Wp64 option from ALL my .cu files from all the configurations - debug, release and emulator.

What else do I need to change to stop showing the warning?

Thanks for the answer in advance!

I removed the Wp64 warning as follows in the Proect / template.

Selecting template (not template.cu) (first line under Solution). then Project / Properties / Configuration Properties / C/C++ / General set
Detect 64-bit Portability issues to NO - (maybe you missed this setting?)

Then, also (maybe you already did this, but just in case)
Selecting template.cu then Project / Properties / Configuration Properties / Custom Build Setup / Command Line - edit to remove /Wp64

Just doing these two items removed the warning. I am using XP 32-bit with VS Expess 2008

Hope the above helps you in whatever project you were using