Cannot access the internet via USB connection

Hi,
I am using a Jetson Orin NX 16GB on a Orin Nano devkit carrier board.
Flashed succesfully with:

wget https://developer.nvidia.com/downloads/embedded/l4t/r36_release_v2.0/release/Jetson_Linux_R36.2.0_aarch64.tbz2
wget https://developer.nvidia.com/downloads/embedded/l4t/r36_release_v2.0/release/Tegra_Linux_Sample-Root-Filesystem_R36.2.0_aarch64.tbz2

tar xvf Jetson_Linux_R36.2.0_aarch64.tbz2
sudo tar xvpf Tegra_Linux_Sample-Root-Filesystem_R36.2.0_aarch64.tbz2 -C Linux_for_Tegra/rootfs/
cd Linux_for_Tegra/

sudo ./apply_binaries.sh
sudo ./tools/l4t_flash_prerequisites.sh
sudo ./tools/l4t_create_default_user.sh -u xxx -p xxx -n xxx --accept-license
sudo ./tools/kernel_flash/l4t_initrd_flash.sh \
    --external-device nvme0n1p1 \
    -c ./tools/kernel_flash/flash_l4t_t234_nvme.xml \
    -p "-c ./bootloader/generic/cfg/flash_t234_qspi.xml" \
    --showlogs \
    --network usb0 \
    jetson-orin-nano-devkit nvme0n1p1

I can ping the jetson from my host (ping 192.168.55.1) and my host from the jetson (ping 192.168.55.100) via serial (picocom -b 115200 /dev/ttyUSB0).
But I cannot access the internet from the jetson via the host.
I recall that I could do this with old Jetson Nano some years ago.
Is there any way to make it work? (plugging an Ethernet cable works, but I’d like to prepare my board without having to connect it to my local network).

Thanks

That would be a “standard” setup on the host PC. You need to enable forwarding. I’m assuming your host is Ubuntu 18.04. Here is just a general search for enabling that (adjust the search for your specific Linux release; note that I quoted “ubuntu 18.04” in the search):
https://www.google.com/search?q=%22ubuntu+18.04%22+how+to+enable+port+forwarding&sca_esv=eae1723b12d3aedd&ei=HycUZqG6LKDZwbkPmJmKuA0&ved=0ahUKEwjhxe-PkLOFAxWgbDABHZiMAtcQ4dUDCBE&uact=5&oq=%22ubuntu+18.04%22+how+to+enable+port+forwarding&gs_lp=Egxnd3Mtd2l6LXNlcnAiLCJ1YnVudHUgMTguMDQiIGhvdyB0byBlbmFibGUgcG9ydCBmb3J3YXJkaW5nMggQABiABBiiBDIIEAAYgAQYogRI-RJQ7AdYsxFwAXgBkAEAmAGFAqAB4AaqAQUwLjUuMbgBA8gBAPgBAZgCB6AC-gbCAgoQABhHGNYEGLADwgIGEAAYCBgewgILEAAYgAQYigUYhgPCAggQIRigARjDBJgDAIgGAZAGCJIHBTEuNS4xoAeiEw&sclient=gws-wiz-serp

Thanks.
My host is Ubuntu 22.04 and I have IPV4 port forwarding enabled.
I guess I am missing the forwarding part on the firewall (nftables).

It’s ok now, indeed it had nothing to do with Jetson itself but a Linux/network “issue”.
With the following commands it worked (it could work with iptables-nft or iptables if not using nftables):

interface=wlp4s0
hostip=192.168.1.2

sudo nft add table nat
sudo nft 'add chain nat POSTROUTING { type nat hook postrouting priority srcnat; policy accept; }'
sudo nft add rule nat POSTROUTING ip saddr 192.168.55.0/24 oif $interface snat to $hostip

I’ll see later if I make it persistent.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.