Cannot boot on Fedora 36 (510.68.02 driver). "Failed to start nvidia-powerd.service"

System: GTX 3070ti (FE), Ryzen 5600x, 32GB RAM, 2560x1440@170Hz (desktop system)
Output of nvidia-bug-report.sh: UNTITLED - Pastebin Service
Driver version: 510.68.02 from RPM Fusion repositories
Distro: Fedora 36 (clean install)

I tried to install the proprietary driver from RPM Fusion but it causes boot to hang with the error message “Failed to start nvidia-powerd.service”.

I don’t think that it is a wayland or X server issue - it comes before it in the boot process and I tried to troubleshoot it by booting to the text console with the same results.

This system previously ran fine on Fedora 35 and X server is useable with the nouveau driver.

The only similar issue that I can find on google is this /r/Fedora/comments/unfbel/fedora_36_akmodnvidia_driver/
(sorry, the forum only allows me to put in one link!)

Thanks for your help in advance!

Output of systemctl status nvidia-powerd.service:


× nvidia-powerd.service - nvidia-powerd service
     Loaded: loaded (/usr/lib/systemd/system/nvidia-powerd.service; enabled; vendor preset: enabled)
     Active: failed (Result: exit-code) since Mon 2022-05-30 17:26:37 BST; 2min 15s ago
    Process: 1052 ExecStart=/usr/bin/nvidia-powerd (code=exited, status=1/FAILURE)
   Main PID: 1052 (code=exited, status=1/FAILURE)
        CPU: 4ms

May 30 17:26:37 gimli systemd[1]: Starting nvidia-powerd.service - nvidia-powerd service...
May 30 17:26:37 gimli /usr/bin/nvidia-powerd[1052]: nvidia-powerd version:1.0(build 1)
May 30 17:26:37 gimli /usr/bin/nvidia-powerd[1052]: Allocate client failed 38
May 30 17:26:37 gimli /usr/bin/nvidia-powerd[1052]: Failed to initialize RM Client
May 30 17:26:37 gimli systemd[1]: nvidia-powerd.service: Main process exited, code=exited, status=1/FAILURE
May 30 17:26:37 gimli systemd[1]: nvidia-powerd.service: Failed with result 'exit-code'.
May 30 17:26:37 gimli systemd[1]: Failed to start nvidia-powerd.service - nvidia-powerd service.

Picture of the boot screen with plymouth disabled: https://photos.app.goo.gl/XfaYFSyB6fN4RdPq6
(note the multicoloured bar 1/3 of the way down the screen is real - it’s not an artifact of the camera!)

Uploading output of nvidia-bug-report.sh in this post. It won’t allow me to attach to the first post due to number of links allowed for new users.
nvidia-bug-report.log.gz (81.3 KB)

There are no nvidia modules available. Please try reinstalling kernel headers and driver.

Thanks generix.

I’ve already tried this unfortunately. I did a second clean install of Fedora 36 and installed the driver with the same result. I also tried uninstalling the driver and reinstalling with the same result.

I ran the various debug commands using nouveau since I couldn’t boot using the proprietary driver. Is that maybe why it’s showing the modules as unavailable?

For reference, I used the instructions here: Howto/NVIDIA - RPM Fusion I made sure that I was on the latest kernel and rebooted prior to doing the installation as per instructions. I also let the computer sit for 15 mins and checked htop that there were no processes running to ensure that it had fully built.

For anyone else searching, it looks like a known issue. More info here: Black login screen when nvidia v470.103.01 drivers are installed on fedora 36 fresh install - #7 by dragontome

I have this trouble on my Fedora 36

If I restart the service, my Fedora back to work

So I do systemctl stop nvidia-powerd.service ;
sudo dnf reinstall xorg-x11-drv-nvidia-cuda-3:515.57.-1.fc36.*
systemctl start nvidia-powerd.service