Cannot boot TK1 and cannot reinstall JetPack

I cannot boot my TK1. When powers on, the fan works and the power light is on, but the HDMI has no output. Also, no power on the USB port and the LED light in the network port doesn’t blink, so I assume the network port still has no power. In one word, expect the power light is on and the fan works, there are no any differences when power is on and off.

I try to reinstall the JetPack, but failed. The log is:
RCM communication completed
BCT sent successfully
sending file: tegra124-jetson_tk1-pm375-000-c00-00.dtb

  • 59637/59637 bytes sent
    tegra124-jetson_tk1-pm375-000-c00-00.dtb sent successfully
    odm data: 0x6009c000
    downloading bootloader – load address: 0x83d88000 entry point: 0x83d88000
    download command failed NvError 0x120002
    command failure/warning: bootloader download failed (bad data)
    Failed flashing ardbeg.

It seems the board cannot access the Internet, and also the LED light in the network port doesn’t blink. I have tried to connect the board directly to router or bridge by my computer. But always fails.

I have tried to only install the tegra-os, which doesn’t need to connect the network in the installation. In this case, no errors in the installation, but still, I cannot boot the board. Only fan works and power light is on when I power on the board.

I am assuming maybe I have a hardware failure, but not sure. Have you met this before. How can I make sure that this is a hardware failure?

The error code implies “packet was nacked” (not acknowledged). If install was started and it failed here I wouldn’t be surprised it doesn’t boot and that hardware does not seem to function. A question then arises as to whether this was from host issues (such as using a VM), perhaps the cable or any USB HUB could be an issue, and perhaps the Jetson hardware itself was an issue.

Is there anything special about the host, such as being a VM? Was the cable connected directly to the host, or was there a HUB? If there was a HUB, can you try with direct connect?

Thanks. I didn’t use VM and USB HUB. I guess the “packet was nacked” problem is because my network is not connected. The LED of the network port should blink when the cable in, but it doesn’t in my board. So I guess the network port is broken. Also, if I choose only to install L4T, not CUDA, there is no error in installation. But still, I cannot boot the board.

The error is from USB, not network. Network is never touched during the flash step…network is purely for package additions after flash completes and the Jetson reboots. If software were badly enough broken from a failed flash I could see the possibility that the network be completely unresponsive after the flash. That error though validates flash failed, and also verifies that even if hardware functions, the software likely is in a state that it can’t boot.

As for reinstall without CUDA, but no install error, I think many people mistake invalid video configuration for failure to boot. Having network fail adds to the possibility that it truly didn’t boot, but there are still steps to booting which can succeed even if networking fails. If you look at the serial console (the DB-9 connector), then you will know for sure (many people don’t have a serial cable, but it is very valuable when other things don’t work). Can you get a serial console running? If you have the cable, settings are speed 115200, 8N1, CTS/DTS flow control.

If you do choose to go for RMA, look for “RMA” near the top of this:
https://devtalk.nvidia.com/default/topic/793798/embedded-systems/some-jetson-web-links/