Cannot connect Raspberry Pi v2.1 with Jetson Xavier NX Development Kit via CSI interface on board

So I downloaded the latest JetPack SDK v5.1.1 for Xavier NX Development Kit and attached the raspberry pi camera v2.1 in its csi port.
I have tried various commands, such as:
gst-launch-1.0 nvarguscamerasrc ! ‘video/x-raw(memory:NVMM),width=1920, height=1080, framerate=30/1, format=NV12’ ! nvvidconv ! ‘video/x-raw(memory:NVMM), format=RGBA’ ! nvvidconv ! nvegltransform ! nveglglessink -e

gst-launch-1.0 v4l2src device=/dev/video0 ! ‘video/x-raw,format=NV12,width=3280,height=2464,framerate=21/1’ ! nvvidconv flip-method=2 ! ‘video/x-raw,width=800,height=600’ ! nvvidconv ! nvegltransform ! nveglglessink -e

and many more. The camera is being detected by the board when i run ls /dev/video*

I have spent over a day on this but to no avail. Kindly help

Setting pipeline to PAUSED …

Using winsys: x11
Pipeline is live and does not need PREROLL …
Got context from element ‘eglglessink0’: gst.egl.EGLDisplay=context, display=(GstEGLDisplay)NULL;
Setting pipeline to PLAYING …
New clock: GstSystemClock
Error generated. /dvs/git/dirty/git-master_linux/multimedia/nvgstreamer/gst-nvarguscamera/gstnvarguscamerasrc.cpp, execute:751 No cameras available
WARNING: from element /GstPipeline:pipeline0/GstEglGlesSink:eglglessink0: Pipeline construction is invalid, please add queues.
Additional debug info:
gstbasesink.c(1209): gst_base_sink_query_latency (): /GstPipeline:pipeline0/GstEglGlesSink:eglglessink0:
Not enough buffering available for the processing deadline of 0:00:00.015000000, add enough queues to buffer 0:00:00.015000000 additional data. Shortening processing latency to 0:00:00.000000000.
Got EOS from element “pipeline0”.
Execution ended after 0:00:00.172146018
Setting pipeline to NULL …
Freeing pipeline …
(Argus) Error EndOfFile: Unexpected error in reading socket (in src/rpc/socket/client/ClientSocketManager.cpp, function recvThreadCore(), line 266)
(Argus) Error EndOfFile: Receive worker failure, notifying 1 waiting threads (in src/rpc/socket/client/ClientSocketManager.cpp, function recvThreadCore(), line 339)
(Argus) Error InvalidState: Argus client is exiting with 1 outstanding client threads (in src/rpc/socket/client/ClientSocketManager.cpp, function recvThreadCore(), line 355)
(Argus) Error EndOfFile: Receiving thread terminated with error (in src/rpc/socket/client/ClientSocketManager.cpp, function recvThreadWrapper(), line 368)
(Argus) Error EndOfFile: Client thread received an error from socket (in src/rpc/socket/client/ClientSocketManager.cpp, function send(), line 145)
(Argus) Error EndOfFile: (propagating from src/rpc/socket/client/SocketClientDispatch.cpp, function dispatch(), line 91)

hello kzm23,

we’ve tested locally and it’s confirmed the camera functionality works normally.
the environment setup is… JetPack SDK v5.1.1 / Xavier NX DevKit / Raspberry Pi camera v2.1, IMX219.

here’re test pipelines for your reference,
$ gst-launch-1.0 nvarguscamerasrc ! 'video/x-raw(memory:NVMM),width=1920, height=1080, framerate=30/1, format=NV12' ! nvvidconv ! 'video/x-raw(memory:NVMM), format=RGBA' ! nvvidconv ! nvegltransform ! nveglglessink -e
$ gst-launch-1.0 nvarguscamerasrc ! 'video/x-raw(memory:NVMM),width=1920, height=1080, framerate=30/1, format=NV12' ! nvvidconv ! xvimagesink

you cannot use v4l2src to access IMX219 camera stream
please see-also Camera API Matrix for reference.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.