Cannot connect to System Monitor Backend

Ok, sorry it didn’t work. I’d like to ask you two things then.

  1. collect logs in .nvidia-omniverse\logs folder. You can zip the entire folder and either attach it here or send it to “dduka at nvidia.com” by email.

  2. Can you go %LOCALAPPDATA%\ov\pkg\nucleus-workstation-2020.3.2-rc.9\System Monitor and try running omni-system-monitor.exe manually from cmd console? Does it startup? A tray icon should appear and in the process tree you should have omni-system-monitor running.

I understand debugging like this through the forum is suboptimal, but unfortunately that’s the best I can offer for now. Hopefully logs from step 1 will be enough for us to get to the bottom of this.

Hello,
i checked the folders where omniverse is installed and i couldn´t find what you meant on step 1.If you mean the logs folder on the web browser, that one i cant open at all to check.I will attach a screenshot of that.
And step too didnt work either.

Thank you for your support.

Sorry its to big, got to seperate…

%LOCALAPPDATA%ovpkgnucleus-workstation-2020.3.2-rc.9System Monitor_PT1.zip (7.04 MB)

%LOCALAPPDATA%ovpkgnucleus-workstation-2020.3.2-rc.9System Monitor_PT1.zip (7.04 MB)

PT2

%LOCALAPPDATA%ovpkgnucleus-workstation-2020.3.2-rc.9System Monitor_PT2.zip (5.16 MB)

PT3

%LOCALAPPDATA%ovpkgnucleus-workstation-2020.3.2-rc.9System Monitor_PT3.zip (3.62 MB)

Same issue here from original post.

Thanks for posting your logs, thanks!

There seems to be a problem with one of the configuration files, can you send this one too please - %LOCALAPPDATA%\NVIDIA Corporation\Omniverse\omniverse.toml?

1 Like

omniverse.toml (39 Bytes)

Thanks! That one looks fine, but according to logs, this one %LOCALAPPDATA%.nvidia-omniverse\config\Cache\ports.toml might be the culprit. Could you please send it as well? Sorry that it takes that many steps to resolve, we’re gathering as much info as we can to make sure this won’t happen in the future.

No Problem…Here is the file requested. Thanks for your Help.

ports.toml (256 Bytes)

Thanks for sharing this! That’s the problematic file. Can you try substituting your version of this file with this one? I hope this resolves the issue. You might need to restart launcher and you definitely need to restart the cache service and the system monitor. The easiest way to do this I think is to follow the flow from my comment above:

“Can you try this please - close Omniverse Launcher, close System Monitor application (if you have it running in the tray). Hit Ctrl+Esc (task manager) and find any processes starting with “omni” (such as omni-system-monitor) and end them. Then start Omniverse Launcher and try starting Nucleus from collaboration tab again”

ports.toml (256 Bytes)

OMG it worked,after almost 1 month trying.Thank you very much,you are the best.
Im so happy its working finally.

Ok, thanks for helping out with this, we’ve gathered some information and hopefully this won’t happen in the future.

Hi, I’ve found the same problem but sadly couldn’t fix it with the above recommendations. I’m running Omniverse on Ubuntu 18.04 with Nvidia Driver 460.67 (the only version I can use Isaac Sim with). I attach all the logs and config files requested before on this discussion. Thank you in advance.
nvidia_omniverse_logs.zip (25.5 MB)
omniverse.toml (1.6 KB)
ports.toml (244 Bytes)

I created an internal bug for this issue (OM-38994).

Hi,

I recently tested a new PC and found this problem, so I’ll share the information.
I just built the Omniverse environment on a Windows 10 PC with nothing installed in its initial state.

Local Nucleus Service 2021.3.2

In the Omniverse Launcher, I was able to see information about Nucleus.
However, I could not see localhost:3080 from my web browser.
I got a “Cannot connect to System Monitor Backend” message in my browser.

The default web browser was Edge, so I replaced it with Google Chrome.
Now it works fine in the browser.

Hey guys,
I’m also having the same problem. Also on release notes I noticed it’s on " Nucleus Workstation 2021.2.6" and there’s no update section on the Nvidia launcher to update nucleus. So don’t know if that could be an underlying cause as well, cause I saw on the release notes it says “Fixes incorrect link on the package page in the Omniverse Launcher” so can’t tell if it’s 2021.2.6 installing a wrong package or its my own system that’s hindering the access. Look forward to getting some help from you guys, I’ll be grateful.

Same issue. Tried just about everythign excep tfor replacing th eport file. Which iim going to do pending another pc restart (Just in case it is sitll firewall related)

SO after resetting my entire network setup and enabling port forwarding to no avail, what I did was utilize the Omniverse cleaner tool to set everything back to default state with all apps and connections and preferences removed.
After reinstalling everything, things are working as connected. Happy its working again. Hope this helps someone.