"Cannot create profiling file" error when using nvprof

The error occurred when I tried to execute the following command.

nvprof --analysis-metrics -o vectorAdd.nvprof vectorAdd

Any idea how to solve this problem? Thanks!

One possibility:
You might be in a directory that you don’t have write permissions to. For example, on linux, the vectorAdd executable that you are trying to profile might normally have been built in a directory like:


Typical users don’t have write access to that directory, and nvprof obviously needs write access to save the file:

-o vectorAdd.nvprof

If this is the case, copy the vectorAdd executable to one of your own user/local directories that you have write access to, and repeat your command there.

Hi, I tried this solution, and unfortunately it didn’t work out. Is there anything else I can do?
I ran this on Windows 10, and I have noticed a couple of warnings saying some metrics cannot be found on my device. I wonder if any of this is relevant.

I think I’ve found what the problem was. Turns out there were Chinese characters in the path name. After adjusting the path name, everything seemed fine.