Cannot disable display/VGX (headless mode) with Tesla P100 since version 375.xx

Hello

I’ve got servers with Tesla K80 and others with Tesla P100. I’m running X server on them in headless mode. There is no display devices connected to them (there is even no adapter on the HW for that for Tesla systems). Access to X servers is done using remote display protocol.

There is only a Screen declared, no modeline, no display devices and X is managing only a screen. Some full screen app is adapting the Screen sizes dynamically.

$ xrandr
Screen 0: minimum 8 x 8, current 1680 x 951, maximum 2560 x 1600
$

Everything was working fine on them, using CentOS 7.3, Xorg 1.17 and drivers up to 367.xx, with both K80 and P100.

Since we upgraded our system to CentOS 7.4, drivers 384.111, there is a new “DVI-D-0” device which automatically appeared. Xorg.0.log shows:

[2270266.385] (--) NVIDIA(0): Valid display device(s) on GPU-0 at PCI:2:0:0
[2270266.385] (--) NVIDIA(0):     DFP-0
[2270266.385] (--) NVIDIA(0):     DFP-1
[2270266.385] (--) NVIDIA(0):     DFP-2
[2270266.385] (--) NVIDIA(0):     DFP-3
...
[2270266.391] (--) NVIDIA(GPU-0): NVIDIA VGX (DFP-0): connected
[2270266.391] (--) NVIDIA(GPU-0): NVIDIA VGX (DFP-0): External TMDS
...
[2270266.391] (==) NVIDIA(0): 
[2270266.391] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[2270266.391] (==) NVIDIA(0):     will be used as the requested mode.
[2270266.391] (==) NVIDIA(0): 
[2270266.391] (II) NVIDIA(0): Validated MetaModes:
[2270266.391] (II) NVIDIA(0):     "DFP-0:nvidia-auto-select"

And xrandr is more verbose:

$ xrandr
Screen 0: minimum 8 x 8, current 800 x 600, maximum 2560 x 1600
Screen 0: minimum 8 x 8, current 1400 x 1050, maximum 2560 x 1600
DVI-D-0 connected primary 1024x768+0+0 (normal left inverted right x axis y axis) 700mm x 400mm panning 1400x1050+0+0
   1024x768      85.00*+  86.96    75.05    60.04    85.00    75.03    70.07    60.00  
   1856x1392     75.00    60.01  
   1792x1344     75.00    60.01  
   1600x1200     85.00    75.00    70.00    65.00    60.00  
   1400x1050     74.76    59.98  
   1280x1024     85.02    75.02    60.02  
   1280x960      85.00    60.00  
   ...
   416x312       74.66  
   400x300       85.27    75.12    72.19    60.32    56.34  
   360x200       85.04  
   320x240       85.18    75.00    72.81    60.05  
   320x200       85.27  
   320x175       85.27  
DVI-D-1 disconnected (normal left inverted right x axis y axis)
DVI-D-2 disconnected (normal left inverted right x axis y axis)
DVI-D-3 disconnected (normal left inverted right x axis y axis)

Strangely, this new devices do not appeared when running with K80.
I’ve tried a lot of NVidia xorg.conf options to no avail so far.

I would like to get rid of these display devices and back to the previous behavior.

My xorg.conf:

Section "Files"
    ModulePath   "/usr/lib64/xorg/modules/extensions/nvidia"
    ModulePath   "/usr/lib64/xorg/modules"
EndSection

Section "Device"
    Identifier "Videocard0"
    Driver "nvidia"
    VendorName "NVidia"
    BusID "PCI:2:0:0"
    Option "DPI" "90x90"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device "Videocard0"
    DefaultDepth 24
    SubSection "Display"
           Viewport 0 0
           Virtual  1920    1400
           Depth 24
    EndSubSection
EndSection

I have the same problem. Did you ever find a solution?