Cannot enable cpu core 4-5

Hi,
Today I try to enable cpu4 and cpu5 but it can not.
I try

sudo -s
echo 1 > /sys/devices/system/cpu/cpu4/online
echo 1 > /sys/devices/system/cpu/cpu5/online

But both of them get error “bash: echo: write error: Invalid argument”.
I also try to change mode of /sys/devices/system/cpu/cpu4/online but it is not successful.
When I check
cat /sys/devices/system/cpu/offline -> it shows “4-5”
cat /sys/devices/system/cpu/online -> it shows “0-3”
cat /sys/devices/system/cpu/present -> it shows “0-3”
Are there any idea to solve this problem.
Thank in advance.

Hi Quang_OpenStack, what happens if you try running ~/jetson_clocks.sh or nvpmodel tool? Are those able to enable the CPU cores?
You can double check it by running ~/tegrastats

Dear dusty_nv,
I also checked with ~/jetson_clocks.sh and nvpmodel tool but there was no lucky.

NVPM ERROR: Error writing to /sys/devices/system/cpu/cpu4/online: 22
NVPM ERROR: failed to write PARAM CPU_ONLINE: ARG CORE_4: PATH: /sys/devices/system/cpu/cpu4/online VAL: 1
NVPM ERROR: failed to set power mode!
NVPM ERROR: Failed to exec option requests!

tegrastats only show operation of 4 cpu core

RAM 372/7851MB (lfb 1759x4MB) cpu [0%,0%,0%,0%]@1574
RAM 372/7851MB (lfb 1759x4MB) cpu [1%,0%,1%,0%]@345
RAM 372/7851MB (lfb 1759x4MB) cpu [0%,1%,0%,2%]@345
RAM 372/7851MB (lfb 1759x4MB) cpu [1%,1%,0%,2%]@345
RAM 372/7851MB (lfb 1759x4MB) cpu [2%,0%,0%,2%]@345
RAM 372/7851MB (lfb 1759x4MB) cpu [2%,0%,0%,2%]@345

Do you have any suggestion?
Best regards.

Hi,
I found the problem.
when i check /proc/cmdline, it shows that maxcpus=4, that is the reason why we only can enable CPU core 0-3. So I change maxcpus parameter on u-boot environment to maxcpus=6 and then I can enable all of CPU core after finishing booting.
Best regards.