Cannot enter the graphical interface

I worked on RS232 with another device today and the ubuntu had no free space. But before I worked on RS232, it had at least 900Mb. I tried “startx”, but it gave me some error.

below are two screen shot

http://imgur.com/a/xwwOw

X may fail if not enough space is available for temporary files and sockets. In the case of no space left there isn’t much you can do other than removing some of the excess. If you are unable to do so you can clone, work on the clone image under loopback mount, and then flash with the edited clone. For clone info see:
http://elinux.org/Jetson/Cloning

Do you what cause no space? I just used RS232, and didn’t write anything on space.

Thanks

No idea what might had filled your filesystem, but you can check with

sudo df

If your / mount point is 98% used or more, then you can try to see where it is used with :

sudo du -sh /*

and then dig into biggest folders to find out if something unexpected has been growing somewhere.

I was about to ask the same thing @Honey_Patouceul just asked :)

A comment on why I mentioned cloning is that a cloned image can be mounted on loopback and explored as an exact match of what is on the Jetson…if you can’t run basic testing because of the disk being full, then you can run from your host on the clone and investigate that way.

Should you choose to clone and mount the image on loopback you might consider using this program on your host: “filelight”. filelight is a graphical pie chart of directories and subdirectories which will let you see graphically where the space went. Without that you probably have to drill down with the commands given by @Honey_Patouceul. A typical place where file space is consumed without knowing why is if the logs in “/var/log/” directory were filling up with errors…the above commands can help you check this.

If it turns out you cannot delete files directly from the Jetson, then you could delete unneeded files from the clone and then flash with the clone (you’d end up with an exact match of the edited clone).