Cannot execute the power command when doing USB eye-pattern compliance test with the repeater cable attached

HI, we had USB issue before which the USB device cannot work with a certain NX.

After that post, we tried to do the USB eye-pattern compliance test and got the result as below
image

Since this is not good enough we want to know if the repeater cable can improve.
However we got error message when we tried to execute the power command as below

[2023-07-10 12:22:10.020] nvidia@neto-meti:~$ sudo sh -c ‘echo on > /sys/bus/usb/devices/usb1/power/contro l’
[2023-07-10 12:22:16.957] [sudo] password for nvidia:
[2023-07-10 12:22:19.565] nvidia@neto-meti:~$ [ 43.617244] usb 1-2: Device not responding to setup address.
[2023-07-10 12:22:19.882] [ 43.825116] usb 1-2: Device not responding to setup address.
[2023-07-10 12:22:20.083] [ 44.032662] usb 1-2: device not accepting address 6, error -71
[2023-07-10 12:22:20.231] [ 44.153166] usb 1-2: Device not responding to setup address.
[2023-07-10 12:22:20.416] [ 44.361050] usb 1-2: Device not responding to setup address.
[2023-07-10 12:22:20.621] [ 44.568676] usb 1-2: device not accepting address 7, error -71
[2023-07-10 12:22:21.621] [ 45.540838] usb 1-2: device descriptor read/64, error -71
[2023-07-10 12:22:21.822] [ 45.768856] usb 1-2: device descriptor read/64, error -71
[2023-07-10 12:22:22.176] [ 46.116846] usb 1-2: device descriptor read/64, error -71
[2023-07-10 12:22:22.392] [ 46.344861] usb 1-2: device descriptor read/64, error -71
[2023-07-10 12:22:22.508] [ 46.452834] usb usb1-port2: unable to enumerate USB device

We also tried to ignore this error message and go through the rest of commands but we still failed to get the test result.

Without the repeater cables the command can be executed normally.

The repeater cables we used:
UGREEN USB Cable Extension Active Repeater Cable B00B2HP2UI
Sanwa Supply KB-USB-R212N

Any suggestion for doing USB eye-pattern compliance test with the repeater cable attached?

Sorry for the late response, our team will do the investigation and provide suggestions soon. Thanks

Does same usb device work fine on devkit?

We just checked that the same usb device work fine on devkit.
Do you have any suggestion to investigate this issue?

Since it works fine on devkit, it means your custom board design may have problem. Please check and compare your design to reference first.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.