cannot find cusparse library in pyculib on anaconda3

I tried to install the latest version of


, but got a problem. I used

conda install pyculib

in anaconda prompt and the installation runs successfully. But when I tried to

import pyculib

, the error occurs:

Traceback (most recent call last):

  File "<ipython-input-1-8322ab764e57>", line 1, in <module>
    import pyculib

  File "C:\Users\rl74173\AppData\Local\Continuum\anaconda3\lib\site-packages\pyculib\", line 49, in <module>
    from . import blas, sparse, fft, rand, sorting

  File "C:\Users\rl74173\AppData\Local\Continuum\anaconda3\lib\site-packages\pyculib\sparse\", line 2, in <module>
    from .api import *

  File "C:\Users\rl74173\AppData\Local\Continuum\anaconda3\lib\site-packages\pyculib\sparse\", line 6, in <module>
    from .binding import (cuSparse, CUSPARSE_INDEX_BASE_ZERO,

  File "C:\Users\rl74173\AppData\Local\Continuum\anaconda3\lib\site-packages\pyculib\sparse\", line 1307, in <module>
    cuSparse = _init_cuSparse()

  File "C:\Users\rl74173\AppData\Local\Continuum\anaconda3\lib\site-packages\pyculib\sparse\", line 1292, in _init_cuSparse
    name, func = _init_api_function(k, v)

  File "C:\Users\rl74173\AppData\Local\Continuum\anaconda3\lib\site-packages\pyculib\sparse\", line 1237, in _init_api_function
    lib = libcusparse()

  File "C:\Users\rl74173\AppData\Local\Continuum\anaconda3\lib\site-packages\pyculib\utils\", line 20, in __new__

Exception: Cannot open library for cusparse:
library cusparse not found

I have the same problem when trying to use

anaconda accelarate


Is this library missing in the latest version? I was able to use pyculib before. I can import pycuda and numba. I am using Anaconda3, python 3.6 on windows 10 pro.

I’m experiencing the same problem. Bump


It works.

How would I go about applying that? I’m working with Windows 10.

You would issue that command in python, before you import numba or pyculib

It works for me. Thank you!

I tried typing

os.environ['NUMBAPRO_CUDALIB']='C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v9.2\bin'

in Anaconda Prompt and in Python code. Neither of those worked.

I’m not sure I understand what you mean by “issue that command in python.” I tried typing it in Python code and the Anaconda prompt and it didn’t work.