Cannot flash Jetson AGX orin: "Reading board information failed"

Hi,

No, I feel you are accessing to the wrong /dev/ttyACM0. If you have “micro usb” connected on your jetson, please remove it too.

Please be aware that “micro usb” and “type C” are two different things. Only the one from “type C” can make you run the OEM config.

What I am talking about is: both micro usb and type C port will give you /dev/ttyACM0… but its functionality are different.

Okay got it.

So the type c besides the 40 pin header can help me to connect to it using the ssh.

$ lsusb
Bus 004 Device 006: ID 0955:7020 NVidia Corp.

I can use ssh to connect to it. FINALLY!!! THANKS!

Using the micro USB for debugging, I can see the low level commands and their progress.

$lsusb
Bus 003 Device 013: ID 0955:7045 NVidia Corp.

How can I get the display to work now?

If I upgrade to 5.0.2, then the only way to ssh into using type C would be lost.

Any suggestions?
Thank you again!

Hi,

Could you share me the log (/var/log/Xorg.0.log) under the situation that have display connected?

Hi,

Here they are:
Xorg.0.log (22.0 KB)
Xorg.0.log.old (19.2 KB)

Best,
Kulbir

Hi,

The log says it is still rel-34. Could you share the log based on rel-35.1 (jetpack5.0.2) ?

Hi,

I updated to 5.0.2 and now I cannot connect via SSH.
I cannot connect using the /dev/ttyACM0 port either.

I did confirm that the IP address of Jetson Orin is 192.168.55.1 before I rebooted it.

I tried powering the jetson using barrel jack and then connecting the usb c above barrel jack to laptop. But it did not work.

I see the following pn /dev/ttyACM0:

Terminal ready
[   47.760007] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[   47.762834] usb usb2-port1: config error
[   51.839697] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[   51.840082] usb usb2-port1: config error
[   55.911669] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[   55.916393] usb usb2-port1: config error

Any suggestions on ways to connect to the 5.0.2 jetson?
Please let me know.

Thank you

Hi,

Sorry that could you clarify what was working before?
I am not sure what was working on your side 1 hour ago and now you tell me it is broken again…

Sorry for the confusion.

Jetpack 5.0.1 DP was working on SSH only. Display did not work. SO I thought maybe upgrading to 5.0.2 would help.

Then I upgraded to Jetpack 5.0.2 using the following:
I updated the etc/apt/sources.list.d/nvidia-l4t-apt-source.list file to point to the 35.1 repo on both lines. Finally, I ran the following commands:

sudo apt update
sudo apt dist-upgrade
sudo apt install --fix-broken -o Dpkg::Options::="--force-overwrite"
sudo reboot

After that the usb c port stopped working. Now I cannot SSH into it.

I am not sure if you toally not get into the situation…
so let me remind it again… I posted a patch in previous comment. And that patch is for fixing the usb port issue…

You need to manually reflash the device after applying the patch.

Yes,

I already tried that patch,
Here are the modified files:

  1. p3701.conf.common (8.7 KB)

  2. p3737-0000+p3701-0000.conf (4.0 KB)

I can try it again using the command :

sudo ./flash.sh jetson-agx-orin-devkit mmcblk0p1

I used the SDK manager earlier.
THank you.

Could you share how you flashed the board? Is the board really getting flashed ?

I used the SDK manager. Everytime, it says, 100% success and flash complete in the SDK manager.

I also check the logs at /dev/ttyACM0.

Here are the pictures:

after apply the patch, please use flash.sh to flash to make sure sdkmanager didn’t overwrite your file again.

1 Like

if you always get stuck in oem config because of /dev/ttyACM0 is not accessaible on type C… then just run l4t_create_default_users.sh tool under your Linux_for_Tegra folder…

So OEM config could be bypassed…

1 Like

Output after using the command

sudo ./flash.sh jetson-agx-orin-devkit mmcblk0p1

OUTPUT:

[ 625.7697 ] Bootloader version 01.00.0000
[ 625.8044 ] Writing partition A_MEM_BCT with mem_coldboot_sigheader.bct.encrypt [ 243712 bytes ]
[ 625.8052 ] [................................................] 100%
[ 628.8181 ] tegradevflash_v2 --write B_MEM_BCT mem_coldboot_sigheader.bct.encrypt
[ 628.8205 ] Bootloader version 01.00.0000
[ 628.8494 ] Writing partition B_MEM_BCT with mem_coldboot_sigheader.bct.encrypt [ 243712 bytes ]
[ 628.8503 ] [................................................] 100%
[ 631.8621 ] Flashing completed

[ 631.8623 ] Coldbooting the device
[ 631.8652 ] tegrarcm_v2 --chip 0x23 0 --ismb2
[ 631.8676 ] MB2 version 01.00.0000
[ 631.8962 ] Coldbooting the device
[ 631.8980 ] tegrarcm_v2 --chip 0x23 0 --reboot coldboot
[ 631.8987 ] MB2 version 01.00.0000
*** The target t186ref has been flashed successfully. ***
Reset the board to boot from internal eMMC.

Should I just reboot the Jetson normally?
Or in recovery mode?
What does “Reset the board to boot from internal eMMC.” mean?

It means is has been successfully flashed and now it would boot up from the emmc…

No more recovery mode needed…

Now:

$ ssh companion@192.168.55.1
ssh: connect to host 192.168.55.1 port 22: Connection refused

On /dev/ttyACM0:

[   15.177971] using random self ethernet address
[   15.182572] using random host ethernet address
[   15.195943] nvidia: loading out-of-tree module taints kernel.
[   15.261163] 1 fixed-partitions partitions found on MTD device spi6.0
[   15.267827] Creating 1 MTD partitions on "spi6.0":
[   15.272783] 0x000000000000-0x000004000000 : "Whole_flash0"
[   15.448304] OF: graph: no port node found in /i2c@c240000/ucsi_ccg@8/connector@0
[   15.543065] OF: graph: no port node found in /i2c@c240000/ucsi_ccg@8/connector@0
[   15.552786] OF: graph: no port node found in /i2c@c240000/ucsi_ccg@8/connector@0
[   15.730300] using random self ethernet address
[   15.734904] using random host ethernet address
[   16.850181] CPU8: shutdown
[   17.003985] CPU9: shutdown
[   17.135446] CPU10: shutdown
[   17.279604] IRQ 122: no longer affine to CPU11
[   17.284585] CPU11: shutdown
[   23.080025] Please complete system configuration setup on the serial port provided by Jetson's USB device mode connection. e.g. /dev/ttyACMx where x can 0, 1, 2 etc.

Running the script l4t_create_default_users.sh .

OUTPUT:

~/nvidia/nvidia_sdk/JetPack_5.0.2_Linux_JETSON_AGX_ORIN_TARGETS/Linux_for_Tegra/tools
$ sudo ./l4t_create_default_user.sh 
[sudo] password for kulbir: 
Creating: Username - nvidia, Password - MDQ2MzIw, Autologin - false
Adding user `nvidia' to group `gdm' ...
Adding user nvidia to group gdm
Done.
Adding user `gdm' to group `video' ...
Adding user gdm to group video
Done.
Creating: Hostname - tegra-ubuntu

How can I ssh into it now?

I see a new user was created by the name of nvidia.

But still cannot SSH,

$ ssh nvidia@192.168.55.1
ssh: connect to host 192.168.55.1 port 22: Connection refused

I can still see the L4T-README drive. So that means the usb C port near the 40 pin header works? THe patch worked?

Please let me know. THank you!

Hi,

Let me list out every method here…

  1. Configure your user account by running picocom to /dev/ttyACM0… I am not sure if you really did that before even in jp5.0.1 DP…

  2. if /dev/ttyACM0 fails to show up on your host, then just run l4t_create_default_users.sh on your host machine. And then you need to reflash the device again. This time your host will have user accoount configured already. Thus, you can use the console on “micro usb” now. In this setup, forget about anything happened on type C. We just ignore the usage on it.

btw, “192.168.55.1” IP should be simiar case as /dev/ttyACM0… they are both from the type C port.

But maybe your host machine didn’t support it because of lacking of driver…