Cannot flash OS image to Orin Developer Kit via SDK Manager

Can you just boot up your Orin device and share me the uart log? Please be aware that I mean boot up, not recovery mode or flash.

Hi, @WayneWWW ,
Yes, I can boot up my Orin device. I attached the uarg log file on booting up.
The command lsusb showed “Bus 001 Device 011: ID 0955:7020 NVIDIA Corp. L4T (Linux for Tegra) running on Tegra”.
log220803_uart_bootup.txt (70.6 KB)

Your log is truncated in each line. Please try to dump full log.

Hi, @WayneWWW ,
I dumped full log.
log220803_minicom_bootup2.txt (78.4 KB)

Hi

Some questions after I checked the log. May need your reply for them.

  1. According to the log, your board is still able to boot up, are you able to operate with the the uart console?

  2. If you can, could you dump this result and share to us?

sudo i2cdump -y 0 0x50

If you cannot , could you share the sticker on your module?

  1. Have you ever flashed this device successfully before?

Hi, @WayneWWW ,

  1. Yes, I can login via the uart console.

  2. I attached results by i2cdump.

  3. Yes.
    log220803_i2cdump.txt (1.3 KB)

Have you ever flashed this device successfully before?

Hello, is your “yes” for this question? Then you mean this board suddenly cannot be flashed anymore?

Hi, @WayneWWW ,
Yes, I flashed this device before, but I cannot do now.

Hi,

So your last successful flash was trying to flash “jetson-agx-orin-devkit-as-nx-16gb.conf”? with same host as what you are using now?

Hi, @WayneWWW ,
Yes, My last successful flash on this device was to flash “jetson-agx-orin-devkit-as-nx-16gb” with the same host.

Could you use the uart console with command “sudo reboot forced-recovery” to put the board instead and run flash.sh again and share me the log (host +uart) again?

I feel this is not an issue that could be resolved by using next release…

Hi, @WayneWWW ,
I logoned via the uart console and executed “sudo reboot forced-recovery”. After a few minutes, I run flash.sh in the recovery mode. I attached the host and uart log files.
log220803_4_minicom.txt (4.8 KB)
log220803_4_flash_ubuntu2004.txt (11.3 KB)

Hi Rayer,

Please wait for the next release first and try it. It shall be ready in 1~2 weeks.
Let me know the result after you try.

1 Like

The JetPack5.0.2 GA release has been published, please get it a try. Thanks

Hi, @kayccc and @WayneWWW ,

I tried JetPack 5.0.2. Terminal shows “Bus 001 Device 010: ID 0955:7023 NVIDIA Corp. APX”, but showed “File rcm_state open failed” again. I attach the host and uart log files.
log220822_ubuntu2004.txt (11.3 KB)
log220822_minicom.txt (4.7 KB)

Are you still able to boot up the board and check log with minicom?

Yes. I saved boot log with minicom.
log220822_minicom_boot.cap (79.1 KB)

Hi,

No, I mean are you still able to boot up and let it enter the ubuntu console? But not always in recovery mode.

Yes, I can login ubuntu with minicom.

If you flash the board with sdkmanager +jp5.0.2, will it still tell the same error?