Cannot Flash TX2 NX on A203 V2....Please Help

Please Help. Every techniques of flashing this TX2 NX has not worked. lsusb lists the proper TX2 NX SOM as per instructions. Using SDK manager 1.7.3-9053 allows me to select the proper SOM in OP1 but nothing further. On the board I have triple checked recovery mode. Flashing to eMMC with command-line ends without success. I sent email request for support from vendor a week ago but have not received a response. Please help.

We’re not able to help as that carrier board was designed by Seeed.
You better to conact with them to get the support.

@baozhu.zuo please help to check if can have suggestions.

Hello @user8751,

Do you have any error logs that you can share when flashing to the TX2 NX? That would help me to look into the issue further.

Thank you.

Thank you for your response. Please find attached a log file.

Install_log_file (49.4 KB)

Thank you very much.



Hello @user8751,

Thank you for the logs.

Could you please help me with the following?

  1. Attach the output of “lsusb” command after entering recovery mode
  2. Version of JetPack you are trying to install
  3. Host Operating System name and version
  4. Details of problems faced when trying to flash via SDK Manager

Thank you.

  1. Regarding lsusb: Please find the attached screenshot from the terminal window.

2 Regarding Version of Jetpack: 4.6
3. Host Operating System is Brand New HP Linux Laptop 8 GB Ram running Ubuntu 20.04.1.

  1. SDK Manager does not populate the OS and does not allow Step 2. See attached images.

Thank You very much for your continued support



Hello @user8751,

Thank you for the info and attachments. Looks like it has successfully entered recovery mode.

It seems that SDK Manager is not yet fully supported by Ubuntu 20.04. I just tested with my Ubuntu 20.04 machine and got the same error as yours. However, when I tried with a Ubuntu 18.04 machine, it was showing all the options as normal and could flash successfully.

Is it possible for you to try on a Ubuntu 18.04 machine? Maybe a VM? I have tried this on Ubuntu 18.04 running on VMware Workstation Player.

Thank you.

OK. I will load 18.04 and see if i can flash via SDK manager. Will report back to you the results.

Thank you so much.

1 Like

Thank you for the response. I have tried 18.04 and I do get the options. I am able to complete the steps. I’m on DSL so it is painfully slow. Is there anyway the flashing proceed be sped up a bit???

Hello Baozhu - I am making small progress and can finally use the sdk manager. Still have not flashed the board yet. Instructions say to remove power? This cannot be correct unless the RTC supplies enough for the flash. Also there is nothing that states pressing the reset button in forced recovery mode. Doesn’t the reset button get pushed? Please advise. Thanks so much

Hello @user8751,

Could you please share a screenshot of the step you are stuck at the moment?

Thank you.

Currently I am just trying to flash the OS and nothing more. Using the SDK manager to guide the flashing process, I continue to generate “Not in Forced Recovery Mode”.

This is getting really painful financially. SDK manager and the wiki instruction do not agree as to the process to force recovery mode.

All contact states are Normally open, correct?

I have tried every conceivable combination using 1.Reset / 2.Recovery / 3.Power. I have tried jumper wire, tactile switches, and also tried reset to no avail.



sdkm-2022-03-10-06-38-01.log (171 KB)

Sorry to jump out. I think there is something wrong here

Our sdkmanager tool officially does not supprot on any VM. Some users may have some tricks to let their VM work with sdkm. However, not everyone is that lucky to do this.

From my point of view , I would suggest you try with a native x86_64 ubuntu 18.04 host. The reason I mentioned x86_64 is because some users may want to use another jetson to flash. This is also not suppoted.

And the method to enter recovery mode is not complicated either.

case 1. If your board is not powered on, then ->recovery pin/button (hold) → power on the board → board in recovery mode.

case 2. If your board is already powered on, replace the “power” in case1 with “reset”. No need to touch power pin/button in this case.

Thank you Wayne for the information. I purchased a dedicated Linux laptop and loaded ubuntu 20.04 and SDK manager would not work. When I dropped back to 18.04 there was no support for wireless Com. So I resorted back to VMware with some luck. I cannot afford luck anymore. This has gotten so expensive. Hope my customer doesn’t loose faith in me.

Thank you for your continued support.

I think you should use wired connection on your host since the data to downloaded by sdkm is not a small one.

Wayne - Doesn’t the board need to be flashed first?

When I said the “host”, I mean your Linux laptop. Thus, I don’t know why you asked me about the board.

My comment does not say anything related to the board…

Sorry Wayne, my confusion.