Cannot get cuda 2.2 running at all on 130m

Please help me! Its been two days in a row of screwing around. I instructed my boss to buy a Acer Aspire AS5739G-6132 notebook which has a GT 130m card with 1gb of video ram. No matter what he installs he cannot get cuda running.

Its a 64 bit version of the virus of an OS piece of crap known as vista.

Tried: drivers that came with device, nothing
Tried: cuda notebook link here (for both 64 and 32 bit) http://www.nvidia.com/object/cuda_get.html
Tried: 100 m series notebook drivers here : http://www.nvidia.com/Download/index.aspx?lang=en-us

The latter, which claims it gives cuda 2.2 seemed really promising, but it fails, and then manages to screw up cuda altogether and makes cudaDriverGetVersion report 0.

The 100 m series notebook driver install completes with the “install did not complete correctly” error (image attached). What freakin drivers are gonna work with this thing? >.<

I only supply cudart.dll with my app, not anything else.

Ok. I’m remote accessing the PC and all the installers only allow me to install/update the HD audio component. Nothing for video. NO clue why. Device managers shows nvidia geforce 130 M

the older acer driver install allows me to check video drivers as well as audio