Cannot get Geforce GTX 550TI working with Ubuntu 20.04

Hi
I’ve been trying to get my Geforce GTX 550 Ti working with the Ubuntu, but I cannot, so far I tried :

  • Download from nvidia the linux driver and disable Nouveau.
    With this, the pc hangs after login…, I checked another tty and I see the nvidia driver is
    being used, also set the nomodeset is added into grub.
    -After several attempts and looking into forums, I decided to reinstall .
    -Now with a clean install I selected the “sofware update” option “additional drivers” and selected 440, after reboot and also with and without nomodeset; still the driver does not load.
    I check nvidia-settings and still no nvidia driver is loaded, I looked into the nvidia debug logs and it shows a message that this board is supported by 390.xx legacy drivers
    and that 440 will ignore the GPU, but not sure why in the “ubuntu-drivers device” command shows as 440 the recommended driver.
  • Now I tried with driver 390 and it ask me to download the driver which basically got me in a loop now.

I dont want to keep messing with this and better ask the experts… can you suggest ?