Cannot get nvenc to set DAR correctly

I’m trying to convert a 1920x1080 video to 720x480 while keeping its aspect ratio(16:9) with h264_nvenc by setting the DAR to 16:9. However, the resulting video has DAR of 20:11 according to ffprobe.

Stream #0:0[0x1f41]: Video: h264 (Main) ([27][0][0][0] / 0x001B), yuv420p(top first), 720x480 [SAR 40:33 DAR 20:11], 29.97 fps, 59.94 tbr, 90k tbn, 59.94 tbc

I own a Quadro P2000(using driver version 390.87) and using ffmpeg on CentOS 7(x86_64) to do the conversion.

A related problem, or more likely the same problem is mentioned on the Geforce forum(https://forums.geforce.com/default/topic/1009796/nvenc-wrong-dar-if-image-size-is-720x576</span></blockquote>) and seems like the problem has been solved for Geforce drivers.

In the reported link, it seems it was fixed in windows driver 397.31 . Maybe you should try latest 396 linux drivers.

Malakudi, thank you for your reply.

The highest driver version I can get is 390.87 from the driver download page(https://www.nvidia.com/Download/index.aspx). But after googling for a higher linux driver I found this(https://www.nvidia.com/download/driverResults.aspx/137211/en-us).

Quadro P2000 is on the supported product list, so I’ll give it a try. Do you have any idea why this driver isn’t showing up when searching for the driver from the web page I mentioned above? Perhaps the download type might be the problem but I have no choice except the “Linux Long Lived Driver” option.

I use this link: https://www.nvidia.com/object/unix.html
396.xx is marked “short lived” but is not beta or something like that. Actually if you want to use Video SDK 8.2 features, you HAVE to use 396.xx driver.

Thank you for making things a lot clearer for me.

Is it fixed wirh 396.xx then? We now have 410.x as well (for RTX series, but I think they also work on GTX).

I tried with the 396.xx linux driver and it worked. I haven’t tried the 410.x since 396.xx worked and had no idea it was out.