Cannot get to run Bazel!

I want to use Isaac on my Jetson AGX Xavier
I followed the steps to install the Isaac SDK from: https://docs.nvidia.com/isaac/isaac/doc/setup.html#installing-dependencies-on-robots

When I tried to build an application using the command:
bazel build //apps/samples/stereo_dummy

it returns error, bazel: command not found.
Is Bazel really installed by the dependency script?

I tried to install Bazel 0.19.2 from:
https://github.com/bazelbuild/bazel/releases/tag/0.19.2

I get the following error when I try bazel:

/home/nvidiax/bin/bazel: line 88: /home/nvidiax/.bazel/bin/bazel-real: cannot execute binary file: Exec format error
/home/nvidiax/bin/bazel: line 88: /home/nvidiax/.bazel/bin/bazel-real: Success

As per the documentation in, https://docs.bazel.build/versions/0.19.2/install-ubuntu.html
only 16.04 (LTS) and 14.04 (LTS) are listed under supported Ubuntu Linux platforms. Is 18.04 supported by this version?

Have I missed anything? Is there any other way to build and run Issac applications.
Please help! Thanks in advance!

Kira36, the ISAAC SDK documentation at https://docs.nvidia.com/isaac/isaac/doc/setup.html#prerequisites provides you with instructions for installing the dependencies on a Ubuntu 18.04 LTS linux PC.

ISAAC SDK requires to be run on a Ubuntu 18.04 desktop PC, workstation, or a Linux VM. The SDK provides the necessary scripts to prepare the Jetson target ( engine/build/scripts/install_dependencies_jetson.sh ) and to deploy your ISAAC application ( engine/build/deploy.sh )

if i can’t install Isaac SDK on the AGX Xavier Developer Kit , what is the use ? You mean to say , i nned another workstation with Nvidia GPU to install Isaac Sdk and deploy it to AGX Xavier . what if , i choose to use AGX Xavier Developer kit as work station instead and deploy Isaac on another Jetson product ! It sounds absurd , that one cannot use Isaac on Nvidia AGX Xavier Developer kit !!

I am also experiencing this error. Is it true that the isaac SDK can only deploy to the Jetson and not run natively on the Jetson?

I am currently trying to install bazel on the Jetson and am finding it difficult through both the repo and the from the binaries