Cannot install 12.8 on Mac OS X

Hi,
I downloaded PGI workstation 12.8 for Mac. But when I was trying to install it, the installer popped an error:

PGI Compilers and Tools 12.8 for MacOS X can’t be installed on this computer.
XCode Version is too old! Xcode Version 3.2 or higher is required for this installation.

I’m actually using Xcode 4.3.3 with Lion so suppose it should be fine. Is there any way to resolve this issue? Thank you very much.

Hi Yinghai Lu,

Our customer service folks ask:

  1. do you have gcc installed? If not, do you have the Xcode command line
    tool installed?

2.run the following
% sudo xcode-select -switch /Applications/Xcode.app/Contents/Developer
% /usr/bin/xcode-select -print-path
#make sure that it prints /Applications/Xcode.app/Contents/Developer

  • Mat

Hi, Mat,
The following line helped resolve the problem. Thanks.

[quote
% sudo xcode-select -switch /Applications/Xcode.app/Contents/Developer
% /usr/bin/xcode-select -print-path
#make sure that it prints /Applications/Xcode.app/Contents/Developer
[/quote]