Cannot install avdec_h264 in deepstream 7.0 docker image

• Hardware Platform
GPU
• DeepStream Version
7.0
• TensorRT Version
as in nvcr.io/nvidia/deepstream:7.0-gc-triton-devel
• NVIDIA GPU Driver Version
535.183.01
• Issue Type
bug
• How to reproduce the issue ?
Run nvcr.io/nvidia/deepstream:7.0-gc-triton-devel docker with:

docker run -it --rm --privileged nvcr.io/nvidia/deepstream:7.0-gc-triton-devel bash

install gstreamer1.0-libav

apt-get install gstreamer1.0-libav

gst-inspect-1.0 avdec_h264 returns: “No such element or plugin ‘avdec_h264’”

Same installation process works on docker.io/library/ubuntu:22.04 image.

1 Like

Please use /opt/nvidia/deepstream/deepstream/user_additional_install.sh to install the gstreamer plugin.

These plugins have been packaged into the docker image, but due to GPL reasons, some shared libraries have been deleted, so you need to run the above script

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.